<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012011070101001">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="google-site-verification" content="TAth4vGpZLIsu4GRdUzOD0-_kO6THbfE3G4NAPTNNH4"><meta name="description" content="WISCONSIN - As the number of COVID-19 cases surge in Wisconsin, state health officials say hospitals are running out of beds and staff."><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content='Evers on COVID-19: "Things have worsened quickly"'><meta property="og:description" content="WISCONSIN - As the number of COVID-19 cases surge in Wisconsin, state health officials say hospitals are running out of beds and staff."><meta property="og:url" content="https://racinecountyeye.com/covid-19-2/"><meta property="og:site_name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta property="article:publisher" content="https://www.facebook.com/racinecountyeye"><meta property="article:author" content="https://www.facebook.com/racinecountyeye?ref=hl"><meta property="article:published_time" content="2020-11-18T23:53:21+00:00"><meta property="article:modified_time" content="2020-11-19T00:01:16+00:00"><meta property="og:image" content="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?fit=1200%2C675&amp;ssl=1"><meta property="og:image:width" content="1200"><meta property="og:image:height" content="675"><meta property="fb:app_id" content="1225990354219564"><meta name="twitter:card" content="summary"><meta name="twitter:creator" content="@racinecountyeye"><meta name="twitter:site" content="@racinecountyeye"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Denise Lockwood"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="4 minutes"><meta name="generator" content="Site Kit by Google 1.20.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="application-name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="wp-parsely_version" id="wp-parsely_version" content="2.2"><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://racinecountyeye.com"><meta name="generator" content="AMP Plugin v2.0.6; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=270%2C270&amp;ssl=1"><title>Evers on COVID-19: "Things have worsened quickly"</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.ampproject.org"><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//v0.wordpress.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" id="amp-analytics-js" async custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-consent-0.1.js" async="" custom-element="amp-consent"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><script src="https://cdn.ampproject.org/v0/amp-twitter-0.1.js" async="" custom-element="amp-twitter"></script><script src="https://cdn.ampproject.org/v0/amp-youtube-0.1.js" async="" custom-element="amp-youtube"></script><link rel="icon" href="https://racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-joseph-fonts-css" href="https://fonts.googleapis.com/css?family=Old+Standard+TT%3A400%2C400i%2C700%7CEB+Garamond%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Jetpack Site Verification Tags --><!-- This site is optimized with the Yoast SEO Premium plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://racinecountyeye.com/covid-19-2/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://racinecountyeye.com/#website","url":"https://racinecountyeye.com/","name":"Local News I Racine County Eye - Racine, Wisconsin","description":"","potentialAction":[{"@type":"SearchAction","target":"https://racinecountyeye.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://racinecountyeye.com/covid-19-2/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?fit=1200%2C675&ssl=1","width":1200,"height":675,"caption":"COVID-19, COVID, COVID19, Wisconsin COVID-19"},{"@type":"WebPage","@id":"https://racinecountyeye.com/covid-19-2/#webpage","url":"https://racinecountyeye.com/covid-19-2/","name":"Evers on COVID-19: \"Things have worsened quickly\"","isPartOf":{"@id":"https://racinecountyeye.com/#website"},"primaryImageOfPage":{"@id":"https://racinecountyeye.com/covid-19-2/#primaryimage"},"datePublished":"2020-11-18T23:53:21+00:00","dateModified":"2020-11-19T00:01:16+00:00","author":{"@id":"https://racinecountyeye.com/#/schema/person/db4c713b9d30745dbb01c4bfbc21d81c"},"description":"WISCONSIN - As the number of COVID-19 cases surge in Wisconsin, state health officials say hospitals are running out of beds and staff.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://racinecountyeye.com/covid-19-2/"]}]},{"@type":"Person","@id":"https://racinecountyeye.com/#/schema/person/db4c713b9d30745dbb01c4bfbc21d81c","name":"Denise Lockwood","image":{"@type":"ImageObject","@id":"https://racinecountyeye.com/#personlogo","inLanguage":"en-US","url":"https://racinecountyeye.com/wp-content/uploads/2014/01/denise.jpg","caption":"Denise Lockwood"},"description":"Denise Lockwood has an extensive background in traditional and non-traditional media. She has written for Patch.com, the Milwaukee Business Journal, Milwaukee Magazine and the Kenosha News.","sameAs":["https://www.racinecountyeye.com","https://www.facebook.com/racinecountyeye?ref=hl","https://twitter.com/@racinecountyeye"]}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Feed" href="https://racinecountyeye.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Comments Feed" href="https://racinecountyeye.com/comments/feed/"><link rel="alternate" type="text/calendar" title="Local News I Racine County Eye - Racine, Wisconsin » iCal Feed" href="https://racinecountyeye.com/calendar/?ical=1"><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Evers on COVID-19: “Things have worsened quickly” Comments Feed" href="https://racinecountyeye.com/covid-19-2/feed/"><link rel="https://api.w.org/" href="https://racinecountyeye.com/wp-json/"><link rel="alternate" type="application/json" href="https://racinecountyeye.com/wp-json/wp/v2/posts/389400"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://racinecountyeye.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://racinecountyeye.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/pbFN9G-1DiE"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fcovid-19-2%2F"><link rel="alternate" type="text/xml+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fcovid-19-2%2F&amp;format=xml"><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/racinecountyeye.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&popups=[]&settings={\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":false,\"newspack_newsletters_non_interative_mode\":\"0\",\"all_segments\":[]}&visit={\"post_id\":\"389400\",\"categories\":\"1,18296,4,16104\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://racinecountyeye.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1"><!-- BEGIN wp-parsely Plugin Version 2.2 --><script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/racinecountyeye.com\/covid-19-2\/"},"headline":"Evers on COVID-19: &#8220;Things have worsened quickly&#8221;","url":"http:\/\/racinecountyeye.com\/covid-19-2\/","thumbnailUrl":"https:\/\/i0.wp.com\/racinecountyeye.com\/wp-content\/uploads\/2020\/11\/Untitled-design-58-1.png?resize=150%2C150&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i0.wp.com\/racinecountyeye.com\/wp-content\/uploads\/2020\/11\/Untitled-design-58-1.png?resize=150%2C150&ssl=1"},"dateCreated":"2020-11-18T23:53:21Z","datePublished":"2020-11-18T23:53:21Z","dateModified":"2020-11-18T23:53:21Z","articleSection":"Breaking","author":[{"@type":"Person","name":"Denise Lockwood"}],"creator":["Denise Lockwood"],"publisher":{"@type":"Organization","name":"Local News I Racine County Eye - Racine, Wisconsin"},"keywords":["covid","covid-19","covid19","wisconsin"]}
		</script><!-- END wp-parsely Plugin Version 2.2 --><link rel="https://theeventscalendar.com/" href="https://racinecountyeye.com/wp-json/tribe/events/v1/"><link rel="pingback" href="https://racinecountyeye.com/xmlrpc.php"><!--noscript--><!--/noscript--><!-- WooCommerce Facebook Integration Begin --><!-- WooCommerce Facebook Integration End --><link rel="apple-touch-icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template post-template-single-wide post-template-single-wide-php single single-post postid-389400 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js tribe-no-js singular hide-homepage-title hide-site-tagline h-nsub h-sb h-ll h-dh h-cta has-sidebar has-featured-image single-featured-image-behind has-large-featured-image categories-hidden tags-hidden">
		<div class="newspack_global_ad global_above_header">
			<div id="div-gpt-amp-ht_728x90-5fb5d16f31985-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>		</div>
			<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-main-navigation" class="main-menu"><li id="menu-item-375417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-375417"><a href="https://racinecountyeye.com">HOME</a></li>
<li id="menu-item-363246" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-363246"><a href="https://racinecountyeye.com/category/news/" aria-haspopup="true" aria-expanded="false">NEWS</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363247"><a href="https://racinecountyeye.com/category/news/business/">Business</a></li>
	<li id="menu-item-29809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29809"><a href="https://racinecountyeye.com/category/news/police-and-fire/">Police &amp; Fire</a></li>
	<li id="menu-item-363250" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-363250"><a href="https://racinecountyeye.com/category/news/government/">Government</a></li>
	<li id="menu-item-363253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363253"><a href="https://racinecountyeye.com/category/news/government/politics/elections/">Elections</a></li>
	<li id="menu-item-387327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-387327"><a href="https://racinecountyeye.com/general-election-2020/">Election Guide 2020</a></li>
	<li id="menu-item-363254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363254"><a href="https://racinecountyeye.com/category/news/edu/">Schools</a></li>
	<li id="menu-item-363255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363255"><a href="https://racinecountyeye.com/category/news/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-363258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363258"><a href="https://racinecountyeye.com/category/community/" aria-haspopup="true" aria-expanded="false">COMMUNITY</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-370402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370402"><a href="https://racinecountyeye.com/category/community/real-estate/" aria-haspopup="true" aria-expanded="false">Real Estate</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-371182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371182"><a href="https://racinecountyeye.com/category/community/real-estate/homes-for-sale/">Homes for Sale</a></li>
		<li id="menu-item-371183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371183"><a href="https://racinecountyeye.com/category/community/real-estate/apartments-for-rent/">Apartments for Rent</a></li>
		<li id="menu-item-371184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371184"><a href="https://racinecountyeye.com/category/community/real-estate/property-transfers/">Property Transfers</a></li>
		<li id="menu-item-371181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371181"><a href="https://racinecountyeye.com/category/community/real-estate/finances/">Finances</a></li>
	</ul>
</li>
	<li id="menu-item-365272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365272"><a href="https://racinecountyeye.com/category/community/public-notices/">Public Notices</a></li>
	<li id="menu-item-29811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29811"><a href="https://racinecountyeye.com/category/community/obituaries/">Obituaries</a></li>
	<li id="menu-item-363260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363260"><a href="https://racinecountyeye.com/category/community/opinion/">Opinion</a></li>
	<li id="menu-item-367754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-367754"><a href="https://racinecountyeye.com/category/community/non-profits/">Non-Profits</a></li>
	<li id="menu-item-370411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370411"><a href="https://racinecountyeye.com/category/community/pets/">Pets</a></li>
</ul>
</li>
<li id="menu-item-363264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363264"><a href="https://racinecountyeye.com/category/culture/" aria-haspopup="true" aria-expanded="false">CULTURE</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363265"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/" aria-haspopup="true" aria-expanded="false">Arts &amp; Entertainment</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-363266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363266"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/comic/">Comic</a></li>
		<li id="menu-item-363267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363267"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/movie-reviews/">Movie reviews</a></li>
		<li id="menu-item-363268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363268"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/quick-spins/">Quick Spins</a></li>
	</ul>
</li>
	<li id="menu-item-363269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363269"><a href="https://racinecountyeye.com/category/culture/food-drinks/">Food &amp; Drinks</a></li>
	<li id="menu-item-363271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363271"><a href="https://racinecountyeye.com/category/culture/shopping/">Shopping</a></li>
	<li id="menu-item-365086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365086"><a href="https://racinecountyeye.com/category/culture/things-to-do/">Things To Do</a></li>
</ul>
</li>
<li id="menu-item-370403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370403"><a href="https://racinecountyeye.com/category/eye-employment/" aria-haspopup="true" aria-expanded="false">EMPLOYMENT</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-370404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370404"><a href="https://racinecountyeye.com/category/news/business/business-spotlight/">Business Spotlight</a></li>
	<li id="menu-item-370405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370405"><a href="https://racinecountyeye.com/category/eye-employment/eye-on-talent/">Eye on Talent</a></li>
	<li id="menu-item-370406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370406"><a href="https://racinecountyeye.com/category/eye-employment/resources/">Resources</a></li>
	<li id="menu-item-370410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370410"><a href="https://racinecountyeye.com/category/eye-employment/wisconsin-jobs/">Wisconsin Jobs</a></li>
	<li id="menu-item-370408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370408"><a href="https://racinecountyeye.com/category/community/real-estate/finances/">Finances</a></li>
</ul>
</li>
<li id="menu-item-78714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78714"><a href="http://racinecountyeye.com/calendar">CALENDAR</a></li>
<li id="menu-item-367628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-367628"><a href="https://www.racinecountyeye.com/racine-and-kenosha-county-nonprofits/">NONPROFITS</a></li>
<li id="menu-item-370533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370533"><a href="https://racinecountyeye.com/category/celebrations/">CELEBRATIONS</a></li>
<li id="menu-item-372792" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-372792"><a href="https://racinecountyeye.com/category/coronavirus/">CORONAVIRUS</a></li>
<li id="menu-item-379485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-379485"><a href="https://racinecountyeye.com/rce-noticias/">RCE Noticias</a></li>
<li id="menu-item-363272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363272"><a href="https://racinecountyeye.com/category/sports/">Sports</a></li>
<li id="menu-item-383581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-383581"><a href="https://racinecountyeye.com/category/kenosha-lens/" aria-haspopup="true" aria-expanded="false">Kenosha Lens</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-383580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383580"><a href="https://racinecountyeye.com/category/kenosha-lens/uptown-observer/">Uptown Observer</a></li>
	<li id="menu-item-383586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383586"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-police-and-fire/">Kenosha Police and Fire</a></li>
	<li id="menu-item-383583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383583"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-government/">Kenosha Government</a></li>
	<li id="menu-item-383588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383588"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-schools/">Kenosha Schools</a></li>
	<li id="menu-item-383582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383582"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-employment/">Kenosha Employment</a></li>
	<li id="menu-item-383587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383587"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-real-estate/">Kenosha Real Estate</a></li>
	<li id="menu-item-383584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383584"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-nonprofits/">Kenosha Nonprofits</a></li>
	<li id="menu-item-383585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383585"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-obituaries/">Kenosha Obituaries</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-secondary" class="secondary-menu"><li id="menu-item-3426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3426"><a rel="httpsracinecountyeyecomgrow-business-low-cost-advertising-solutions" href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/" aria-haspopup="true" aria-expanded="false">Grow Your Business</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-379691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-379691"><a href="https://racinecountyeye.com/category/advertising/">Advertise on RCE</a></li>
	<li id="menu-item-379690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-379690"><a href="https://mailchi.mp/racinecountyeye/connect-with-the-spanish-speaking-community">Advertise on RCE Noticias</a></li>
</ul>
</li>
<li id="menu-item-2530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2530"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-377088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-377088"><a href="https://racinecountyeye.com/racine-county-eye-kicks-off-subscriber-campaign/">Support our publication</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-icons" class="social-links-menu"><li id="menu-item-29805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-29806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-29807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li id="menu-item-29808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
<section id="tribe-events-venue-widget-3" class="below-content widget tribe-events-venue-widget"><h2 class="widget-title">Upcoming events</h2>
<div class="tribe-venue-widget-wrapper">
	<div class="tribe-venue-widget-venue">
		<div class="tribe-venue-widget-venue-name">
			<a href="https://racinecountyeye.com/venue/zoom/" title="Zoom">Zoom</a>		</div>
				<div class="tribe-venue-widget-address">
			<span class="tribe-address">


	<span class="tribe-locality">Racine</span><span class="tribe-delimiter">,</span>

	<abbr class="tribe-region tribe-events-abbr" title="wi">wi</abbr>


	<span class="tribe-country-name">United States</span>

</span>
		</div>
	</div>
					<ul class="tribe-venue-widget-list">
											<li class="type-tribe_events post-388221 tribe-clearfix tribe-events-category-health-and-wellness tribe-events-category-mental-health tribe-events-venue-373511 tribe-events-organizer-158744">
										<h4 class="tribe-event-title">
						<a href="https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/">NAMI Virtual Peer Support Group</a>
					</h4>
					<span class="tribe-event-date-start">November 25 @ 6:00 PM</span> - <span class="tribe-event-time">6:30 PM</span>											<span class="tribe-events-divider">|</span>
						<span class="tribe-events-event-cost">
						Free					</span>
									</li>
											<li class="type-tribe_events post-380685 tribe-clearfix tribe-events-category-health-and-wellness tribe-events-category-mental-health tribe-events-venue-373511 tribe-events-organizer-158744">
										<h4 class="tribe-event-title">
						<a href="https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/">NAMI Teen Talk Group</a>
					</h4>
					<span class="tribe-event-date-start">December 2 @ 10:00 AM</span> - <span class="tribe-event-time">10:30 AM</span>											<span class="tribe-events-divider">|</span>
						<span class="tribe-events-event-cost">
						Free					</span>
									</li>
					</ul>
			
	<a href="https://racinecountyeye.com/venue/zoom/">View all Events at this Venue</a>
</div>
</section><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"NAMI Virtual Peer Support Group","description":"&lt;p&gt;The Peer Support Group is a 90-minute weekly support group for individuals living with a mental illness. The group meets virtually every Wednesday at 2 p.m via zoom. Additionally, in-person peer support groups are available every Monday from 11 a.m. - noon. Also, beginning on November 5th, every other Thursday at 6 p.m. \u200bSupport groups [&hellip;]&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2020/07/NAMI-Racine-Support-Groups.jpg","url":"https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/","startDate":"2020-11-25T18:00:00-06:00","endDate":"2020-11-25T18:30:00-06:00","location":{"@type":"Place","name":"Zoom","description":"","url":"https://racinecountyeye.com/venue/zoom/","address":{"@type":"PostalAddress","addressLocality":"Racine","addressRegion":"wi","addressCountry":"United States"},"telephone":"","sameAs":"zoom.com"},"organizer":{"@type":"Person","name":"NAMI Racine County","description":"&lt;p&gt;Mission:\u00a0NAMI Racine County provides advocacy, education, support, and public awareness so that all individuals and families affected by mental illness can build better lives. \u200b Vision:\u00a0 A compassionate community where all people affected by mental illness live healthy, fulfilling lives.&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2018/04/nami-e1522864073507.jpg","url":"https://racinecountyeye.com/organizer/nami-racine-county/","telephone":"(262) 637-0582","email":"inf&#111;&#64;NAMI&#82;ac&#105;&#110;&#101;&#46;&#111;r&#103;","sameAs":"https://www.namiracinecounty.org/"},"offers":{"@type":"Offer","price":"0","priceCurrency":"$","url":"https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/","category":"primary","availability":"inStock","validFrom":"2020-07-29T00:00:00+00:00"},"performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"NAMI Teen Talk Group","description":"&lt;p&gt;The Teen Talk&nbsp;group is a 60-minute, professionally led support group for high school teens living with mental illness. The group meets on the 1st and 3rd Wednesday each month at 4:00 pm.&nbsp; The first-time attendees require a parent&nbsp;and/or guardian&nbsp;to sign a consent form.&nbsp; Pre-registration is REQUIRED&nbsp;and must be confirmed by calling 262-637-0582 or email Allison [&hellip;]&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2020/07/teen-talk-flyer_orig.jpg","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/","startDate":"2020-12-02T10:00:00-06:00","endDate":"2020-12-02T10:30:00-06:00","location":[{"@type":"VirtualLocation","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/"},{"@type":"Place","name":"Zoom","description":"","url":"https://racinecountyeye.com/venue/zoom/","address":{"@type":"PostalAddress","addressLocality":"Racine","addressRegion":"wi","addressCountry":"United States"},"telephone":"","sameAs":"zoom.com"}],"organizer":{"@type":"Person","name":"NAMI Racine County","description":"&lt;p&gt;Mission:\u00a0NAMI Racine County provides advocacy, education, support, and public awareness so that all individuals and families affected by mental illness can build better lives. \u200b Vision:\u00a0 A compassionate community where all people affected by mental illness live healthy, fulfilling lives.&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2018/04/nami-e1522864073507.jpg","url":"https://racinecountyeye.com/organizer/nami-racine-county/","telephone":"(262) 637-0582","email":"&#105;n&#102;o&#64;NA&#77;&#73;&#82;a&#99;&#105;ne.o&#114;g","sameAs":"https://www.namiracinecounty.org/"},"offers":{"@type":"Offer","price":"0","priceCurrency":"$","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/","category":"primary","availability":"inStock","validFrom":"2020-07-29T00:00:00+00:00"},"performer":"Organization","eventAttendanceMode":"https://schema.org/MixedEventAttendanceMode"}]
</script><section id="twitter_timeline-2" class="below-content widget widget_twitter_timeline"><h2 class="widget-title">2020 Election Polls</h2><amp-twitter data-width="220" data-height="200" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" layout="responsive" data-timeline-source-type="profile" data-timeline-screen-name="2020ElectionPo1" width="220" height="200" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:90.9091%;"></i-amphtml-sizer>My Tweets</amp-twitter></section>
	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
<section id="tribe-events-venue-widget-3" class="below-content widget tribe-events-venue-widget"><h2 class="widget-title">Upcoming events</h2>
<div class="tribe-venue-widget-wrapper">
	<div class="tribe-venue-widget-venue">
		<div class="tribe-venue-widget-venue-name">
			<a href="https://racinecountyeye.com/venue/zoom/" title="Zoom">Zoom</a>		</div>
				<div class="tribe-venue-widget-address">
			<span class="tribe-address">


	<span class="tribe-locality">Racine</span><span class="tribe-delimiter">,</span>

	<abbr class="tribe-region tribe-events-abbr" title="wi">wi</abbr>


	<span class="tribe-country-name">United States</span>

</span>
		</div>
	</div>
					<ul class="tribe-venue-widget-list">
											<li class="type-tribe_events post-388221 tribe-clearfix tribe-events-category-health-and-wellness tribe-events-category-mental-health tribe-events-venue-373511 tribe-events-organizer-158744">
										<h4 class="tribe-event-title">
						<a href="https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/">NAMI Virtual Peer Support Group</a>
					</h4>
					<span class="tribe-event-date-start">November 25 @ 6:00 PM</span> - <span class="tribe-event-time">6:30 PM</span>											<span class="tribe-events-divider">|</span>
						<span class="tribe-events-event-cost">
						Free					</span>
									</li>
											<li class="type-tribe_events post-380685 tribe-clearfix tribe-events-category-health-and-wellness tribe-events-category-mental-health tribe-events-venue-373511 tribe-events-organizer-158744">
										<h4 class="tribe-event-title">
						<a href="https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/">NAMI Teen Talk Group</a>
					</h4>
					<span class="tribe-event-date-start">December 2 @ 10:00 AM</span> - <span class="tribe-event-time">10:30 AM</span>											<span class="tribe-events-divider">|</span>
						<span class="tribe-events-event-cost">
						Free					</span>
									</li>
					</ul>
			
	<a href="https://racinecountyeye.com/venue/zoom/">View all Events at this Venue</a>
</div>
</section><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"NAMI Virtual Peer Support Group","description":"&lt;p&gt;The Peer Support Group is a 90-minute weekly support group for individuals living with a mental illness. The group meets virtually every Wednesday at 2 p.m via zoom. Additionally, in-person peer support groups are available every Monday from 11 a.m. - noon. Also, beginning on November 5th, every other Thursday at 6 p.m. \u200bSupport groups [&hellip;]&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2020/07/NAMI-Racine-Support-Groups.jpg","url":"https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/","startDate":"2020-11-25T18:00:00-06:00","endDate":"2020-11-25T18:30:00-06:00","location":{"@type":"Place","name":"Zoom","description":"","url":"https://racinecountyeye.com/venue/zoom/","address":{"@type":"PostalAddress","addressLocality":"Racine","addressRegion":"wi","addressCountry":"United States"},"telephone":"","sameAs":"zoom.com"},"organizer":{"@type":"Person","name":"NAMI Racine County","description":"&lt;p&gt;Mission:\u00a0NAMI Racine County provides advocacy, education, support, and public awareness so that all individuals and families affected by mental illness can build better lives. \u200b Vision:\u00a0 A compassionate community where all people affected by mental illness live healthy, fulfilling lives.&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2018/04/nami-e1522864073507.jpg","url":"https://racinecountyeye.com/organizer/nami-racine-county/","telephone":"(262) 637-0582","email":"&#105;&#110;fo&#64;&#78;AMIR&#97;c&#105;n&#101;&#46;&#111;rg","sameAs":"https://www.namiracinecounty.org/"},"offers":{"@type":"Offer","price":"0","priceCurrency":"$","url":"https://racinecountyeye.com/calendar/nami-peer-support-group/2020-11-25/","category":"primary","availability":"inStock","validFrom":"2020-07-29T00:00:00+00:00"},"performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"NAMI Teen Talk Group","description":"&lt;p&gt;The Teen Talk&nbsp;group is a 60-minute, professionally led support group for high school teens living with mental illness. The group meets on the 1st and 3rd Wednesday each month at 4:00 pm.&nbsp; The first-time attendees require a parent&nbsp;and/or guardian&nbsp;to sign a consent form.&nbsp; Pre-registration is REQUIRED&nbsp;and must be confirmed by calling 262-637-0582 or email Allison [&hellip;]&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2020/07/teen-talk-flyer_orig.jpg","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/","startDate":"2020-12-02T10:00:00-06:00","endDate":"2020-12-02T10:30:00-06:00","location":[{"@type":"VirtualLocation","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/"},{"@type":"Place","name":"Zoom","description":"","url":"https://racinecountyeye.com/venue/zoom/","address":{"@type":"PostalAddress","addressLocality":"Racine","addressRegion":"wi","addressCountry":"United States"},"telephone":"","sameAs":"zoom.com"}],"organizer":{"@type":"Person","name":"NAMI Racine County","description":"&lt;p&gt;Mission:\u00a0NAMI Racine County provides advocacy, education, support, and public awareness so that all individuals and families affected by mental illness can build better lives. \u200b Vision:\u00a0 A compassionate community where all people affected by mental illness live healthy, fulfilling lives.&lt;/p&gt;\\n","image":"https://racinecountyeye.com/wp-content/uploads/2018/04/nami-e1522864073507.jpg","url":"https://racinecountyeye.com/organizer/nami-racine-county/","telephone":"(262) 637-0582","email":"i&#110;f&#111;&#64;NA&#77;I&#82;&#97;c&#105;&#110;&#101;.org","sameAs":"https://www.namiracinecounty.org/"},"offers":{"@type":"Offer","price":"0","priceCurrency":"$","url":"https://racinecountyeye.com/calendar/nami-teen-talk-group/2020-12-02/","category":"primary","availability":"inStock","validFrom":"2020-07-29T00:00:00+00:00"},"performer":"Organization","eventAttendanceMode":"https://schema.org/MixedEventAttendanceMode"}]
</script><section id="twitter_timeline-2" class="below-content widget widget_twitter_timeline"><h2 class="widget-title">2020 Election Polls</h2><amp-twitter data-width="220" data-height="200" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" layout="responsive" data-timeline-source-type="profile" data-timeline-screen-name="2020ElectionPo1" width="220" height="200" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:90.9091%;"></i-amphtml-sizer>My Tweets</amp-twitter></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
													<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
								<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>								<span>Menu</span>
							</button>
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://racinecountyeye.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE2OScgd2lkdGg9JzIwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://racinecountyeye.com/" rel="home">Local News I Racine County Eye – Racine, Wisconsin</a></p>
					
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

											</div><!-- .nav-wrapper -->

					
					<a class="button mb-cta" href="https://racinecountyeye.com/racine-county-eye-kicks-off-subscriber-campaign/">Donate</a>
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
			<div class="newspack_global_ad global_below_header">
			<div id="div-gpt-amp-ht_728x90-5fb5d16f73f16-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>		</div>
		
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-breaking category-coronavirus category-government category-news tag-covid tag-covid-19 tag-covid19 tag-wisconsin">
		<main id="main" class="site-main">

			
	<div class="featured-image-behind">
		
			<figure class="post-thumbnail">

				<amp-img width="1200" height="675" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?fit=1200%2C675&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="COVID-19, COVID, COVID19, Wisconsin COVID-19" object-fit="cover" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?w=1200&amp;ssl=1 1200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=706%2C397&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzY3NScgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="675" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?fit=1200%2C675&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="COVID-19, COVID, COVID19, Wisconsin COVID-19" loading="lazy" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?w=1200&amp;ssl=1 1200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/11/Untitled-design-58-1.png?resize=706%2C397&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript></amp-img>
			</figure><!-- .post-thumbnail -->

				<div class="wrapper">
			<header class="entry-header">
				
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://racinecountyeye.com/category/breaking/" rel="category tag">Breaking</a></span>		<h1 class="entry-title ">
		Evers on COVID-19: “Things have worsened quickly”	</h1>
	

	<div class="entry-subhead">
					<div class="entry-meta">
				<span class="author-avatar"><amp-img src="https://racinecountyeye.com/wp-content/uploads/2014/01/denise-100x100.jpg" width="80" height="80" alt="Denise Lockwood" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img src="https://racinecountyeye.com/wp-content/uploads/2014/01/denise-100x100.jpg" width="80" height="80" alt="Denise Lockwood" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/denise/">Denise Lockwood</a></span> 			</span><!-- .byline -->
		<span class="posted-on"><time class="entry-date published" datetime="2020-11-18T17:53:21-06:00">November 18th, 2020</time><time class="updated" datetime="2020-11-18T18:01:16-06:00">November 18th, 2020</time></span>			</div><!-- .meta-info -->
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
			</header>
		</div><!-- .wrapper -->
	</div><!-- .featured-image-behind -->

	

				<div class="main-content">

					
<article id="post-389400" class="post-389400 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking category-coronavirus category-government category-news tag-covid tag-covid-19 tag-covid19 tag-wisconsin newspack_spnsrs_tax-need-help-heres-one-stop-shop-for-all-of-your-needs-2 entry">
	<div class="entry-content">

		
		
<div class="wp-block-columns">
<div class="wp-block-column amp-wp-86a7827" data-amp-original-style="flex-basis:66.66%">
<p><strong>WISCONSIN –</strong> With hospitals running out of bed capacity, Governor Tony Evers said Wednesday that he plans to extend the COVID-19 public health emergency and the mask order through at least Jan. 15.</p>



<p>Evers <a href="https://racinecountyeye.com/evers-declares-new-covid-19-public-health-emergency-mask-order/">issued the orders in September</a> and set them to expire on Nov. 21. However, he said he plans to issue new orders that sunset in mid-January.</p>



<p>“We cannot afford to stop or have a gap in some of the only mitigation efforts we still have in place,” Evers said during a media briefing held Wednesday. “So today, I’m announcing that I’ll be declaring a new state of emergency this week and extending our public health emergency until January of next year.”</p>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit aligncenter amp-wp-13076d9" data-amp-original-style="text-align:center"><amp-ad width="728" height="90" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>


<h3>State Supreme Court hears challenges to executive orders</h3>



<p>The public health emergency and face-covering orders have been contraversial with the business community and are currently being challenged in the <a target="_blank" href="https://www.jsonline.com/story/news/politics/2020/11/16/wisconsin-high-court-hears-arguments-decides-fate-covid-19-policies/6309842002/" rel="noreferrer noopener">Wisconsin Supreme Court</a>.</p>



<p>The justices struck down the <a href="https://racinecountyeye.com/breaking-state-supreme-court-overturns-safer-at-home-order-effective-immediately/">stay-at-home order</a> in a 4-3 decision in May. But on Monday, they met on whether they should uphold Evers’ policies that are currently in place to slow the spread of the virus, according to the Milwaukee Journal Sentinel.</p>



<p>The Republican-controlled Legislature didn’t agree to extend the emergency declaration. Evers argued that he could issue multiple emergency declarations due to the threat the pandemic poses over time.</p>



<p>“As many of you also know, our current public health emergency and our face coverings order is being challenged in Wisconsin Supreme Court,” Evers said. “Republicans in the Legislature support this effort. That’s why today I’m also once again calling on Republicans to withdraw their support for this lawsuit and to publicly support our new public health emergency and face conference order.”</p>



<p>Meanwhile, the rhetoric around how to slow the spread of COVID-19 has shifted within the Republican Party.</p>



<p>In a press conference held Monday, State Republicans announced a plan to roll out several key policy initiatives. House Speaker Robin Vos (R-Rochester) said he and his Assembly Republican colleagues plan to put a package of ideas together.</p>



<p>A package could include building a robust testing system, doubling the number of contact tracers, ensuring efficient distribution of a COVID vaccine, helping the health care industry, requiring reform for the unemployment insurance program, and helping small businesses.</p>



<p>“We have to get on the same team; the virus is the enemy, not each other. Wisconsin needs some bipartisan answers,” said Speaker Vos. “These proposals are from our constituents, stakeholder groups, and lawmakers. We look forward to discussing these legislative initiatives with our Senate colleagues and the governor.”</p>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit aligncenter amp-wp-13076d9" data-amp-original-style="text-align:center"><amp-ad width="728" height="90" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>


<h3>Spike in COVID-19 cases, hospitalizations cause the crisis to grow</h3>



<p>The decision to continue the orders comes on the heels of another record-setting number of daily cases and hospitalization rates. On Wednesday, Wisconsin recorded 7,989 new COVID-19 cases, 92 deaths, and 2,277 more people hospitalized.</p>



<p>“I warned last week that the <a target="_blank" href="https://covid19.healthdata.org/united-states-of-america/wisconsin?view=mask-use&amp;tab=trend" rel="noreferrer noopener">Institute for Health Metrics and Evaluation</a> (IHME) estimates that if we continue on the path we’re on, Wisconsin could see 5,000 deaths by the end of this calendar year.</p>



<p>Without a vaccine, the only mitigation tools residents have to slow the spread of the virus are wearing face coverings, social distancing, not being around people they don’t live with, and washing their hands.</p>



<p>But several pharmaceutical companies plan to seek approval for their vaccine candidates from the FDA. State health officials said yesterday that a <a target="_blank" href="https://racinecountyeye.com/covid-19-vaccines-distribution/" rel="noreferrer noopener">limited supply of vaccines</a> could be available to healthcare workers in January.</p>



<p><a target="_blank" href="https://covid19.healthdata.org/united-states-of-america/wisconsin?view=resource-use&amp;tab=trend&amp;resource=all_resources" rel="noreferrer noopener">IHME projects</a> that about 64 percent of Wisconsin residents say they always wear a mask in public, but the target health officials want to see is 95 percent. This would reduce the rate of transmission by 30 percent.</p>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit aligncenter amp-wp-13076d9" data-amp-original-style="text-align:center"><amp-ad width="728" height="90" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>


<h3>Hospitals running out of beds</h3>



<p>The hospitalization rate is also expected to peak in early December, but the impact of the recent surge in cases requiring hospitalization has stressed out hospital resources.</p>



<p>“A strained hospital system puts everyone at risk, whether or not you have COVID-19,” said Andrea Palm, secretary-designee of the Wisconsin Department of Health Services. “Hospital staff are out sick, unable to come to work because they have tested positive for COVID-19 or because they are in quarantine.”</p>



<p>One-third of the hospitals in Wisconsin report a current critical staffing shortage; 41 percent expect to have a critical staffing shortage within a week; multiple hospitals in every region have activated their surge plans. In two regions, every single hospital has activated their surge plan, Palm said.</p>



<p>Immediate bed availability for southeast Wisconsin on Nov. 18 SOURCE: Wisconsin Hospital Association.</p>



<p>“Some have surgical beds set aside, but they are going unused because there is no surgical staff available to staff them,” she said.</p>



<p>This has led hospital administrators to delay non-emergency procedures, and a children’s hospital is accepting adult patients.</p>



<p>“We are filling our intensive care units; nine of our hospitals are at 100 percent capacity,” she said. “There are zero ICU beds available in one region of our state.</p>



<p>“This is not how it’s supposed to be.”</p>
</div>



<div class="wp-block-column amp-wp-4d8e209" data-amp-original-style="flex-basis:33.33%">
<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube"><div class="wp-block-embed__wrapper">
<span class="embed-youtube amp-wp-ad18994" data-amp-original-style="text-align:center; display: block;"><amp-youtube data-videoid="g0KuJs4MGjE" data-param-rel="1" data-param-showsearch="0" data-param-showinfo="1" data-param-iv_load_policy="1" data-param-fs="1" data-param-hl="en-US" data-param-autohide="2" data-param-wmode="transparent" width="1200" height="675" layout="responsive" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:56.2500%;"></i-amphtml-sizer><a href="https://www.youtube.com/watch?v=g0KuJs4MGjE" placeholder><amp-img src="https://i0.wp.com/i.ytimg.com/vi/g0KuJs4MGjE/hqdefault.jpg?w=1200&amp;ssl=1" alt="YouTube Poster" layout="fill" object-fit="cover" class="i-amphtml-layout-fill i-amphtml-layout-size-defined" i-amphtml-layout="fill"><noscript><img src="https://i0.wp.com/i.ytimg.com/vi/g0KuJs4MGjE/hqdefault.jpg?w=1200&amp;ssl=1" loading="lazy" decoding="async" alt="YouTube Poster"></noscript></amp-img></a></amp-youtube></span>
</div></figure>



<amp-iframe width="auto" height="700" src="https://callyourcongressperson.com/datainteractive/5f2851397db7754c3cf27808?state=Wisconsin&amp;partner=racine&amp;start=2020-03-01&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40 i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" frameborder="0" scrolling="no" layout="fixed-height" sandbox="allow-downloads allow-forms allow-modals allow-orientation-lock allow-pointer-lock allow-popups allow-popups-to-escape-sandbox allow-presentation allow-same-origin allow-scripts allow-top-navigation-by-user-activation" data-amp-original-style="display:block;" style="height:700px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe width="100%" height="700px" src="https://callyourcongressperson.com/datainteractive/5f2851397db7754c3cf27808?state=Wisconsin&amp;partner=racine&amp;start=2020-03-01&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40" frameborder="0" scrolling="no" data-amp-original-style="display:block;"></iframe></noscript></amp-iframe>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit aligncenter amp-wp-13076d9" data-amp-original-style="text-align:center"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21820527880/hs_300x250" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"covid-19-2","category":["breaking","coronavirus","government","news"],"ID":389400}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div>


<amp-iframe width="auto" height="700" src="https://callyourcongressperson.com/datainteractive/5f20ed3eaaff4e1186cd46e3?state=Wisconsin&amp;county=Racine&amp;partner=racine&amp;start=2020-03-01&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40 i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" frameborder="0" scrolling="no" layout="fixed-height" sandbox="allow-downloads allow-forms allow-modals allow-orientation-lock allow-pointer-lock allow-popups allow-popups-to-escape-sandbox allow-presentation allow-same-origin allow-scripts allow-top-navigation-by-user-activation" data-amp-original-style="display:block;" style="height:700px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe width="100%" height="700px" src="https://callyourcongressperson.com/datainteractive/5f20ed3eaaff4e1186cd46e3?state=Wisconsin&amp;county=Racine&amp;partner=racine&amp;start=2020-03-01&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40" frameborder="0" scrolling="no" data-amp-original-style="display:block;"></iframe></noscript></amp-iframe>



<amp-iframe width="auto" height="700" src="https://callyourcongressperson.com/datainteractive/5f3c3311d12d831e4684b580?state=Wisconsin&amp;partner=racine&amp;start=2020-04-10&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40 i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" frameborder="0" scrolling="no" layout="fixed-height" sandbox="allow-downloads allow-forms allow-modals allow-orientation-lock allow-pointer-lock allow-popups allow-popups-to-escape-sandbox allow-presentation allow-same-origin allow-scripts allow-top-navigation-by-user-activation" data-amp-original-style="display:block;" style="height:700px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe width="100%" height="700px" src="https://callyourcongressperson.com/datainteractive/5f3c3311d12d831e4684b580?state=Wisconsin&amp;partner=racine&amp;start=2020-04-10&amp;tz=America/Chicago&amp;theme=higeorge" class="hg-data-interactive amp-wp-0adff40" frameborder="0" scrolling="no" data-amp-original-style="display:block;"></iframe></noscript></amp-iframe>



<h3 id="h-individuals-who-test-positive-for-the-covid-19-virus-are-reminded-to">Individuals who test positive for the COVID-19 virus are reminded to:</h3>



<ul><li>Stay home and isolate for a minimum of 10 days after symptom onset. </li><li>If you did not have symptoms and were tested, remain isolated for ten days from the date of testing. </li><li>You can return to work or school on day 11 if free of fever and see an improvement in other symptoms for 24 hours. </li><li>Notify your employer or school if you are positive. </li><li>Notify your close contacts and ask them to quarantine for 14 days from the last day of contact with you.</li></ul>



<p>The rising number of positive cases means that the Racine Health Department may not notify employers of positive cases among employees. </p>
</div>
</div>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-5fb5d16f8eeca" aria-labelledby="related-posts-item-5fb5d16f8eeca-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fb5d16f8eeca-label" href="https://racinecountyeye.com/evers-issues-facial-coverings-order-effective-saturday/">Evers Issues Facial Coverings Order Effective Saturday</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://racinecountyeye.com/evers-issues-facial-coverings-order-effective-saturday/"><amp-img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/tony-evers.jpg?fit=640%2C427&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Racine County Cultural organizations" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/tony-evers.jpg?fit=640%2C427&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Racine County Cultural organizations" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">July 30th, 2020</li><li class="jp-related-posts-i2__post-context">In "CORONAVIRUS"</li></ul><ul id="related-posts-item-5fb5d16f8ef1f" aria-labelledby="related-posts-item-5fb5d16f8ef1f-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fb5d16f8ef1f-label" href="https://racinecountyeye.com/evers-declares-new-covid-19-public-health-emergency-mask-order/">Evers declares new COVID-19 public health emergency, mask order</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://racinecountyeye.com/evers-declares-new-covid-19-public-health-emergency-mask-order/"><amp-img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?fit=640%2C427&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Evers" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?fit=640%2C427&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Evers" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">September 22nd, 2020</li><li class="jp-related-posts-i2__post-context">In "Government"</li></ul><ul id="related-posts-item-5fb5d16f8ef5a" aria-labelledby="related-posts-item-5fb5d16f8ef5a-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fb5d16f8ef5a-label" href="https://racinecountyeye.com/city-emergency-declaration-does-not-extend-safer-at-home-order/">City Emergency Declaration does not extend Safer at Home Order</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://racinecountyeye.com/city-emergency-declaration-does-not-extend-safer-at-home-order/"><amp-img src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/COVID-19.png?fit=600%2C200&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/COVID-19.png?fit=600%2C200&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">May 19th, 2020</li><li class="jp-related-posts-i2__post-context">In "Breaking"</li></ul></div></nav><section id="text-39" class="below-content widget widget_text"><h2 class="widget-title">Love what we do?</h2>			<div class="textwidget"><p>In addition to our education features, we’ll be kicking off a series of stories highlighting how parents, students, and educators are adapting to the impact of COVID-19 on education. If this is important to you, please consider donating to our education reporting fund. https://business.facebook.com/donate/1846323118855149/3262802717172659/</p>
</div>
		</section>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://racinecountyeye.com/tag/covid/" rel="tag">COVID</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/covid-19/" rel="tag">Covid-19</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/covid19/" rel="tag">COVID19</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/wisconsin/" rel="tag">Wisconsin</a></span>	</footer><!-- .entry-footer -->

	
			<div class="author-bio">
				<amp-img src="https://racinecountyeye.com/wp-content/uploads/2014/01/denise-100x100.jpg" width="80" height="80" alt="Denise Lockwood" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img src="https://racinecountyeye.com/wp-content/uploads/2014/01/denise-100x100.jpg" width="80" height="80" alt="Denise Lockwood" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						<div>
							<h2 class="accent-header">
								Denise Lockwood								<span></span>
							</h2>

															<div class="author-meta">
																			<a class="author-email" href="mailto:denise@racinecountyeye.com">
											<svg class="svg-icon" width="18" height="18" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M20 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V6c0-1.1-.9-2-2-2zm0 14H4V8l8 5 8-5v10zm-8-7L4 6h16l-8 5z"></path></svg>											denise@racinecountyeye.com										</a>
																										</div><!-- .author-meta -->
							
						</div>
					</div><!-- .author-bio-header -->

											<p>
							Denise Lockwood has an extensive background in traditional and non-traditional media. She has written for Patch.com, the Milwaukee Business Journal, Milwaukee Magazine and the Kenosha News.							<a class="author-link" href="https://racinecountyeye.com/author/denise/" rel="author">
							More by Denise Lockwood							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
		
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		<p class="must-log-in">You must <a href="https://racinecountyeye.com/wp-login.php?redirect_to=https%3A%2F%2Fracinecountyeye.com%2Fcovid-19-2%2F%23respond">log in</a> to post a comment.</p></div><!-- #comments -->
				</div>

			
		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://racinecountyeye.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE2OScgd2lkdGg9JzIwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-icons-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			
<amp-consent id="eu-cookie-consent" layout="nodisplay" class="widget widget_eu_cookie_law_widget i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
	<script type="application/json">
		{
			"consentInstanceId": "eu-cookie-consent",
			"consentRequired": true,
			"promptUI": "eu-cookie-consent-prompt"
		}
	</script>
	<div class="popupOverlay" id="eu-cookie-consent-prompt">
		<div class="consentPopup" id="eu-cookie-law">
			<form method="get" action="//racinecountyeye.com/covid-19-2/" target="_top">
				<input type="button" on="tap:eu-cookie-consent.accept" class="accept" value="Close and accept" role="button" tabindex="0">
			</form>
			Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br>
To find out more, including how to control cookies, see here:			<a href="https://racinecountyeye.com/terms-conditions/" rel="">
				Cookie Policy			</a>
		</div>
	</div>
</amp-consent>
		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

				<aside class="widget-area" role="complementary" aria-label="Below Footer">
		<div class="wrapper">
			<section id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widget-title">Copyright</h2><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-29815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29815"><a href="https://racinecountyeye.com/about/">About</a></li>
<li id="menu-item-29816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29816"><a href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/">Grow your business with the Racine County Eye and the Kenosha Lens</a></li>
<li id="menu-item-29817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29817"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-354317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-354317"><a href="https://www.racinecountyeye.com/privacy-policy/">Privacy policy</a></li>
</ul></div></section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->

			<div class="wrapper site-info-contain">
													<span class="copyright">© 2020 Local News I Racine County Eye - Racine, Wisconsin.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

				<a class="privacy-policy-link" href="https://racinecountyeye.com/terms-conditions/">Terms &amp; Conditions</a>			</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->




<!-- START Parse.ly Include: Standard -->



<!-- END Parse.ly Include: Standard -->
		
			<div data-amp-original-style="display:none" class="amp-wp-cb45893">
	<div class="grofile-hash-map-8774d6416866e8864e8e110377e97853">
	</div>
	</div>
			<!-- Facebook Pixel Code -->
			<!--noscript-->
				<amp-img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" class="amp-wp-enforced-sizes amp-wp-6a19fc1 i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" data-amp-original-style="display:inline-block" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzEnIHdpZHRoPScxJyB4bWxucz0naHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmcnIHZlcnNpb249JzEuMScvPg=="></i-amphtml-sizer><noscript><img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" data-amp-original-style="display:none" class="amp-wp-cb45893"></noscript></amp-img>
			<!--/noscript-->
			<!-- End Facebook Pixel Code -->
					<amp-install-serviceworker src="/?wp_service_worker=1" data-iframe-src="https://racinecountyeye.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"gtag_id":"UA-128295961-1","config":{"UA-128295961-1":{"groups":"default","linker":[],"dimension2":"breaking,coronavirus,government,news"}}},"optoutElementId":"__gaOptOutExtension","triggers":{"socialShareClickedFacebook":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"facebook","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"facebook\"]"},"socialShareClickedTwitter":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"twitter","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"twitter\"]"},"socialShareClickedWhatsApp":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"whatsapp","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"whatsapp\"]"},"socialShareClickedLinkedIn":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"linkedin","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"linkedin\"]"},"articleRead25":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_label":"Evers on COVID-19: &#8220;Things have worsened quickly&#8221;","event_category":"NTG article milestone","non_interaction":true,"value":25},"event_value":25,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[25]}},"articleRead50":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_label":"Evers on COVID-19: &#8220;Things have worsened quickly&#8221;","event_category":"NTG article milestone","non_interaction":true,"value":50},"event_value":50,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[50]}},"articleRead100":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_label":"Evers on COVID-19: &#8220;Things have worsened quickly&#8221;","event_category":"NTG article milestone","non_interaction":true,"value":100},"event_value":100,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[100]}}}}</script></amp-analytics>
<!-- Google Tag Manager added by Site Kit -->
<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-P7DVBXQ" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>
<!-- End Google Tag Manager -->
<amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"racinecountyeye.com"}}</script></amp-analytics>	
	













































































			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A9.1&amp;blog=172500100&amp;post=389400&amp;tz=-6&amp;srv=racinecountyeye.com&amp;host=racinecountyeye.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated in 1.460 seconds
	159002 bytes batcached for 300 seconds
-->
