<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012101152047000">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="google-site-verification" content="TAth4vGpZLIsu4GRdUzOD0-_kO6THbfE3G4NAPTNNH4"><meta name="description" content="Charter Communications, Inc. announced today the opening of a new Spectrum Store in Mount Pleasant. The Spectrum store gives consumers in the Racine area a convenient option for adding or managing their Spectrum Internet®, TV, Mobile, or Voice services."><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT"><meta property="og:description" content="Charter Communications, Inc. announced today the opening of a new Spectrum Store in Mount Pleasant. The Spectrum store gives consumers in the Racine area a convenient option for adding or managing their Spectrum Internet®, TV, Mobile, or Voice services."><meta property="og:url" content="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/"><meta property="og:site_name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta property="article:publisher" content="https://www.facebook.com/racinecountyeye"><meta property="article:published_time" content="2021-01-21T17:48:49+00:00"><meta property="article:modified_time" content="2021-01-21T17:49:06+00:00"><meta property="og:image" content="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1318%2C872&amp;ssl=1"><meta property="og:image:width" content="1318"><meta property="og:image:height" content="872"><meta name="twitter:card" content="summary"><meta name="twitter:creator" content="@racinecountyeye"><meta name="twitter:site" content="@racinecountyeye"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Racine County Eye"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="2 minutes"><meta name="generator" content="Site Kit by Google 1.24.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="application-name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="wp-parsely_version" id="wp-parsely_version" content="2.3"><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://racinecountyeye.com"><meta name="generator" content="AMP Plugin v2.0.10; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=270%2C270&amp;ssl=1"><title>NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//v0.wordpress.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-carousel-0.2.js" async="" custom-element="amp-carousel"></script><script src="https://cdn.ampproject.org/v0/amp-consent-0.1.js" async="" custom-element="amp-consent"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-selector-0.1.js" async="" custom-element="amp-selector"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-joseph-fonts-css" href="https://fonts.googleapis.com/css?family=Old+Standard+TT%3A400%2C400i%2C700%7CEB+Garamond%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Jetpack Site Verification Tags --><!-- This site is optimized with the Yoast SEO Premium plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://racinecountyeye.com/#website","url":"https://racinecountyeye.com/","name":"Local News I Racine County Eye - Racine, Wisconsin","description":"","potentialAction":[{"@type":"SearchAction","target":"https://racinecountyeye.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1318%2C872&ssl=1","width":1318,"height":872,"caption":"Spectrum Mount Pleasant"},{"@type":"WebPage","@id":"https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/#webpage","url":"https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/","name":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","isPartOf":{"@id":"https://racinecountyeye.com/#website"},"primaryImageOfPage":{"@id":"https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/#primaryimage"},"datePublished":"2021-01-21T17:48:49+00:00","dateModified":"2021-01-21T17:49:06+00:00","author":{"@id":"https://racinecountyeye.com/#/schema/person/51778765af7bbc9a23d80aa59ee9acc6"},"description":"Charter Communications, Inc. announced today the opening of a new Spectrum Store in Mount Pleasant. The Spectrum store gives consumers in the Racine area a convenient option for adding or managing their Spectrum Internet\u00ae, TV, Mobile, or Voice services.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/"]}]},{"@type":"Person","@id":"https://racinecountyeye.com/#/schema/person/51778765af7bbc9a23d80aa59ee9acc6","name":"Racine County Eye","image":{"@type":"ImageObject","@id":"https://racinecountyeye.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&d=mm&r=g","caption":"Racine County Eye"}}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Feed" href="https://racinecountyeye.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Comments Feed" href="https://racinecountyeye.com/comments/feed/"><link rel="alternate" type="text/calendar" title="Local News I Racine County Eye - Racine, Wisconsin » iCal Feed" href="https://racinecountyeye.com/calendar/?ical=1"><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT Comments Feed" href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/feed/"><link rel="https://api.w.org/" href="https://racinecountyeye.com/wp-json/"><link rel="alternate" type="application/json" href="https://racinecountyeye.com/wp-json/wp/v2/posts/394220"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://racinecountyeye.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://racinecountyeye.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/pbFN9G-1Eyo"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fnew-spectrum-store-now-open-in-mount-pleasant%2F"><link rel="alternate" type="text/xml+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fnew-spectrum-store-now-open-in-mount-pleasant%2F&amp;format=xml"><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/racinecountyeye.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&ref=DOCUMENT_REFERRER&popups=[]&settings={\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":\"1\",\"newspack_newsletters_non_interative_mode\":\"0\",\"all_segments\":[],\"newspack_popups_active_campaign_group\":false}&visit={\"post_id\":\"394220\",\"categories\":\"5,16104\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://racinecountyeye.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1"><!-- BEGIN wp-parsely Plugin Version 2.3 --><script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/racinecountyeye.com\/new-spectrum-store-now-open-in-mount-pleasant\/"},"headline":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","url":"http:\/\/racinecountyeye.com\/new-spectrum-store-now-open-in-mount-pleasant\/","thumbnailUrl":"https:\/\/i1.wp.com\/racinecountyeye.com\/wp-content\/uploads\/2021\/01\/Mt.-Pleasant-small.jpg?resize=150%2C150&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/racinecountyeye.com\/wp-content\/uploads\/2021\/01\/Mt.-Pleasant-small.jpg?resize=150%2C150&ssl=1"},"dateCreated":"2021-01-21T17:48:49Z","datePublished":"2021-01-21T17:48:49Z","dateModified":"2021-01-21T17:48:49Z","articleSection":"Business","author":[{"@type":"Person","name":"Racine County Eye"}],"creator":["Racine County Eye"],"publisher":{"@type":"Organization","name":"Local News I Racine County Eye - Racine, Wisconsin","logo":"https:\/\/racinecountyeye.com\/wp-content\/uploads\/2017\/03\/RCE-Web-Logo_transparent-background-1-e1488582236368.png"},"keywords":["mount pleasant","spectrum","spectrum mount pleasant"]}
		</script><!-- END wp-parsely Plugin Version 2.3 --><link rel="https://theeventscalendar.com/" href="https://racinecountyeye.com/wp-json/tribe/events/v1/"><link rel="pingback" href="https://racinecountyeye.com/xmlrpc.php"><!--noscript--><!--/noscript--><!-- WooCommerce Facebook Integration Begin --><!-- WooCommerce Facebook Integration End --><link rel="apple-touch-icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template post-template-single-wide post-template-single-wide-php single single-post postid-394220 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js tribe-no-js singular hide-homepage-title hide-site-tagline h-nsub h-sb h-ll h-dh h-cta has-sidebar has-featured-image single-featured-image-beside has-large-featured-image categories-hidden tags-hidden">
	<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-main-navigation" class="main-menu"><li id="menu-item-375417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-375417"><a href="https://racinecountyeye.com">HOME</a></li>
<li id="menu-item-363246" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-363246"><a href="https://racinecountyeye.com/category/news/" aria-haspopup="true" aria-expanded="false">NEWS</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363247" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-363247"><a href="https://racinecountyeye.com/category/news/business/">Business</a></li>
	<li id="menu-item-29809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29809"><a href="https://racinecountyeye.com/category/news/police-and-fire/">Police &amp; Fire</a></li>
	<li id="menu-item-363250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363250"><a href="https://racinecountyeye.com/category/news/government/">Government</a></li>
	<li id="menu-item-363253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363253"><a href="https://racinecountyeye.com/category/news/government/politics/elections/">Elections</a></li>
	<li id="menu-item-387327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-387327"><a href="https://racinecountyeye.com/general-election-2020/">Election Guide 2020</a></li>
	<li id="menu-item-363254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363254"><a href="https://racinecountyeye.com/category/news/edu/">Schools</a></li>
	<li id="menu-item-363255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363255"><a href="https://racinecountyeye.com/category/news/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-363258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363258"><a href="https://racinecountyeye.com/category/community/" aria-haspopup="true" aria-expanded="false">COMMUNITY</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-365272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365272"><a href="https://racinecountyeye.com/category/community/public-notices/">Public Notices</a></li>
	<li id="menu-item-29811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29811"><a href="https://racinecountyeye.com/category/community/obituaries/">Obituaries</a></li>
	<li id="menu-item-363260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363260"><a href="https://racinecountyeye.com/category/community/opinion/">Opinion</a></li>
	<li id="menu-item-367754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-367754"><a href="https://racinecountyeye.com/category/community/non-profits/">Non-Profits</a></li>
	<li id="menu-item-370411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370411"><a href="https://racinecountyeye.com/category/community/pets/">Pets</a></li>
</ul>
</li>
<li id="menu-item-363264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363264"><a href="https://racinecountyeye.com/category/culture/" aria-haspopup="true" aria-expanded="false">CULTURE</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363265"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/" aria-haspopup="true" aria-expanded="false">Arts &amp; Entertainment</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-363266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363266"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/comic/">Comic</a></li>
		<li id="menu-item-363267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363267"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/movie-reviews/">Movie reviews</a></li>
		<li id="menu-item-363268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363268"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/quick-spins/">Quick Spins</a></li>
	</ul>
</li>
	<li id="menu-item-363269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363269"><a href="https://racinecountyeye.com/category/culture/food-drinks/">Food &amp; Drinks</a></li>
	<li id="menu-item-363271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363271"><a href="https://racinecountyeye.com/category/culture/shopping/">Shopping</a></li>
	<li id="menu-item-365086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365086"><a href="https://racinecountyeye.com/category/culture/things-to-do/">Things To Do</a></li>
</ul>
</li>
<li id="menu-item-370402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370402"><a href="https://racinecountyeye.com/category/community/real-estate/" aria-haspopup="true" aria-expanded="false">REAL ESTATE</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-392443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392443"><a href="https://racinecountyeye.com/category/news/development/">Development</a></li>
	<li id="menu-item-392442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392442"><a href="https://racinecountyeye.com/category/community/real-estate/wow-house/">Wow House</a></li>
	<li id="menu-item-371182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371182"><a href="https://racinecountyeye.com/category/community/real-estate/homes-for-sale/">Homes for Sale</a></li>
	<li id="menu-item-371184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371184"><a href="https://racinecountyeye.com/category/community/real-estate/property-transfers/">Property Transfers</a></li>
	<li id="menu-item-371183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371183"><a href="https://racinecountyeye.com/category/community/real-estate/apartments-for-rent/">Apartments for Rent</a></li>
</ul>
</li>
<li id="menu-item-370403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370403"><a href="https://racinecountyeye.com/category/eye-employment/" aria-haspopup="true" aria-expanded="false">EMPLOYMENT</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-370404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370404"><a href="https://racinecountyeye.com/category/news/business/business-spotlight/">Business Spotlight</a></li>
	<li id="menu-item-370405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370405"><a href="https://racinecountyeye.com/category/eye-employment/eye-on-talent/">Eye on Talent</a></li>
	<li id="menu-item-370406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370406"><a href="https://racinecountyeye.com/category/eye-employment/resources/">Resources</a></li>
	<li id="menu-item-370410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370410"><a href="https://racinecountyeye.com/category/eye-employment/wisconsin-jobs/">Wisconsin Jobs</a></li>
	<li id="menu-item-370408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370408"><a href="https://racinecountyeye.com/category/community/real-estate/finances/">Finances</a></li>
</ul>
</li>
<li id="menu-item-78714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78714"><a href="http://racinecountyeye.com/calendar">CALENDAR</a></li>
<li id="menu-item-367628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-367628"><a href="https://www.racinecountyeye.com/racine-and-kenosha-county-nonprofits/">NONPROFITS</a></li>
<li id="menu-item-372792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-372792"><a href="https://racinecountyeye.com/category/coronavirus/">CORONAVIRUS</a></li>
<li id="menu-item-379485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-379485"><a href="https://racinecountyeye.com/rce-noticias/">RCE Noticias</a></li>
<li id="menu-item-383581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-383581"><a href="https://racinecountyeye.com/category/kenosha-lens/" aria-haspopup="true" aria-expanded="false">Kenosha Lens</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-383580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383580"><a href="https://racinecountyeye.com/category/kenosha-lens/uptown-observer/">Uptown Observer</a></li>
	<li id="menu-item-383586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383586"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-police-and-fire/">Kenosha Police and Fire</a></li>
	<li id="menu-item-383583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383583"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-government/">Kenosha Government</a></li>
	<li id="menu-item-383588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383588"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-schools/">Kenosha Schools</a></li>
	<li id="menu-item-383582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383582"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-employment/">Kenosha Employment</a></li>
	<li id="menu-item-383584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383584"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-nonprofits/">Kenosha Nonprofits</a></li>
	<li id="menu-item-383585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383585"><a href="https://racinecountyeye.com/category/kenosha-lens/kenosha-obituaries/">Kenosha Obituaries</a></li>
</ul>
</li>
<li id="menu-item-390026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-390026"><a href="https://racinecountyeye.com/racine-county-marketplace/">Shop Racine County</a></li>
</ul>	</nav>
	<nav class="secondary-menu nav2 dd-menu" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-secondary" class="secondary-menu"><li id="menu-item-3426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3426"><a rel="httpsracinecountyeyecomgrow-business-low-cost-advertising-solutions" href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/" aria-haspopup="true" aria-expanded="false">Grow Your Business</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-379691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-379691"><a href="https://racinecountyeye.com/category/advertising/">Advertise on RCE</a></li>
	<li id="menu-item-379690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-379690"><a href="https://mailchi.mp/racinecountyeye/connect-with-the-spanish-speaking-community">Advertise on RCE Noticias</a></li>
</ul>
</li>
<li id="menu-item-2530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2530"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-377088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-377088"><a href="https://racinecountyeye.com/racine-county-eye-kicks-off-subscriber-campaign/">Become A Subscriber</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-icons" class="social-links-menu"><li id="menu-item-29805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-29806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-29807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li id="menu-item-29808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
<section id="top-posts-3" class="below-content widget widget_top-posts"><h2 class="widget-title">Top Posts &amp; Pages</h2><ul>				<li>
					<a href="https://racinecountyeye.com/gov-evers-announces-new-public-health-emergency-issues-new-face-coverings-order-as-state-continues-vaccine-distribution/" class="bump-view" data-bump-view="tp">Gov. Evers Announces New Public Health Emergency, Issues New Face Coverings Order as State Continues Vaccine Distribution</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/racine-man-held-on-armed-robbery-attempted-homicide-charges/" class="bump-view" data-bump-view="tp">Racine Man Held on Armed Robbery, Attempted Homicide Charges</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/city-of-racine-launches-mortgage-assistance-program-for-homeowners-economically-impacted-by-covid-19/" class="bump-view" data-bump-view="tp">City of Racine Launches Mortgage Assistance Program for Homeowners Economically Impacted by COVID-19</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/" class="bump-view" data-bump-view="tp">Home</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/adults-age-65-may-get-covid-19-vaccine-next-week/" class="bump-view" data-bump-view="tp">Adults Age 65+ May Get COVID-19 Vaccine Next Week</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/police-theft-construction-site/" class="bump-view" data-bump-view="tp">Racine man charged with theft from construction site</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/some-foodshare-households-will-receive-additional-benefits-for-january/" class="bump-view" data-bump-view="tp">Some FoodShare Households Will Receive Additional Benefits for January</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/kenosha-county-covid-19-vaccine-update/" class="bump-view" data-bump-view="tp">Kenosha County COVID-19 Vaccine Update</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/police-shooting-incident-was-attempted-murder-suicide/" class="bump-view" data-bump-view="tp">Police: Shooting Incident Was Attempted Murder-Suicide</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" class="bump-view" data-bump-view="tp" aria-current="page">NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT</a>					</li>
				</ul></section>
	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
<section id="top-posts-3" class="below-content widget widget_top-posts"><h2 class="widget-title">Top Posts &amp; Pages</h2><ul>				<li>
					<a href="https://racinecountyeye.com/gov-evers-announces-new-public-health-emergency-issues-new-face-coverings-order-as-state-continues-vaccine-distribution/" class="bump-view" data-bump-view="tp">Gov. Evers Announces New Public Health Emergency, Issues New Face Coverings Order as State Continues Vaccine Distribution</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/racine-man-held-on-armed-robbery-attempted-homicide-charges/" class="bump-view" data-bump-view="tp">Racine Man Held on Armed Robbery, Attempted Homicide Charges</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/city-of-racine-launches-mortgage-assistance-program-for-homeowners-economically-impacted-by-covid-19/" class="bump-view" data-bump-view="tp">City of Racine Launches Mortgage Assistance Program for Homeowners Economically Impacted by COVID-19</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/" class="bump-view" data-bump-view="tp">Home</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/adults-age-65-may-get-covid-19-vaccine-next-week/" class="bump-view" data-bump-view="tp">Adults Age 65+ May Get COVID-19 Vaccine Next Week</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/police-theft-construction-site/" class="bump-view" data-bump-view="tp">Racine man charged with theft from construction site</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/some-foodshare-households-will-receive-additional-benefits-for-january/" class="bump-view" data-bump-view="tp">Some FoodShare Households Will Receive Additional Benefits for January</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/kenosha-county-covid-19-vaccine-update/" class="bump-view" data-bump-view="tp">Kenosha County COVID-19 Vaccine Update</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/police-shooting-incident-was-attempted-murder-suicide/" class="bump-view" data-bump-view="tp">Police: Shooting Incident Was Attempted Murder-Suicide</a>					</li>
								<li>
					<a href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" class="bump-view" data-bump-view="tp" aria-current="page">NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT</a>					</li>
				</ul></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

									<div class="top-header-contain desktop-only">
					<div class="wrapper">
													<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
								<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>								<span>Menu</span>
							</button>
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
						
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://racinecountyeye.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE2OScgd2lkdGg9JzIwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://racinecountyeye.com/" rel="home">Local News I Racine County Eye – Racine, Wisconsin</a></p>
					
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

											</div><!-- .nav-wrapper -->

					
					<a class="button mb-cta" href="https://racinecountyeye.com/racine-county-eye-kicks-off-subscriber-campaign/">Donate</a>
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
				<div class="newspack_global_ad global_below_header">
								<div id="div-gpt-amp-ht_728x90-6009e9154c273-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"new-spectrum-store-now-open-in-mount-pleasant","category":["business","news"],"ID":394220}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>			</div>
			
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-business category-news tag-mount-pleasant tag-spectrum tag-spectrum-mount-pleasant">
		<main id="main" class="site-main">

			
	<div class="featured-image-beside">
		<div class="wrapper">
			<header class="entry-header">
				
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://racinecountyeye.com/category/news/" rel="category tag">News</a></span>		<h1 class="entry-title entry-title--with-subtitle">
		NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT	</h1>
			<div class="newspack-post-subtitle">
			Store Will Serve Customers While Adhering to Health and Safety Guidelines		</div>
	

	<div class="entry-subhead">
					<div class="entry-meta">
				<span class="author-avatar"><amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=80&amp;d=mm&amp;r=g" width="80" height="80" alt="Avatar" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=80&amp;d=mm&amp;r=g" width="80" height="80" alt="Avatar" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 photo avatar-default"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span> 			</span><!-- .byline -->
		<span class="posted-on"><time class="entry-date published" datetime="2021-01-21T11:48:49-06:00">3 hours ago</time><time class="updated" datetime="2021-01-21T11:49:06-06:00">January 21st, 2021</time></span>			</div><!-- .meta-info -->
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
			</header>
		</div><!-- .wrapper -->

		
			<figure class="post-thumbnail">

				<amp-img width="1200" height="794" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1200%2C794&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Spectrum Mount Pleasant" object-fit="cover" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?w=1318&amp;ssl=1 1318w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=300%2C198&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1024%2C677&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1200%2C794&amp;ssl=1 1200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=150%2C99&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=706%2C467&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzc5NCcgd2lkdGg9JzEyMDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1200" height="794" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1200%2C794&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="Spectrum Mount Pleasant" loading="lazy" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?w=1318&amp;ssl=1 1318w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=300%2C198&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1024%2C677&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1200%2C794&amp;ssl=1 1200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=150%2C99&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=706%2C467&amp;ssl=1 706w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript></amp-img>
			</figure><!-- .post-thumbnail -->

		
			</div><!-- .featured-image-behind -->


				<div class="main-content">

					
<article id="post-394220" class="post-394220 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-news tag-mount-pleasant tag-spectrum tag-spectrum-mount-pleasant entry">
	<div class="entry-content">

		
		
<p>Charter Communications, Inc. announced today the opening of a new Spectrum Store in Mount Pleasant. The Spectrum store gives consumers in the Racine area a convenient option for adding or managing their Spectrum Internet<sup>®</sup>, TV, Mobile, or Voice services.</p>



<p>“Our Spectrum stores team is here to help our local customers who need support in getting and staying connected,” said Pattie Eliason, Senior Vice President, Spectrum Stores &amp; Retail. “They are working to make our new store in Mount Pleasant a safe, convenient environment to add or manage services, shop for devices and accessories or make payments, while ensuring we adhere to current local and state health and safety guidelines.”</p>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit alignnone amp-wp-e1576f2" data-amp-original-style="text-align:inherit"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21820527880/hs_300x250" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"new-spectrum-store-now-open-in-mount-pleasant","category":["business","news"],"ID":394220}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div>


<p>The new Mount Pleasant store at 5423B Washington Ave. is open weekdays from 10 a.m. to 8 p.m., Saturdays from 10 a.m. to 8 p.m. and Sundays from noon to 5 p.m. To help protect the safety of customers and employees, and in accordance with CDC guidelines and state and local orders, social distancing is required in the store, with occupancy of the store managed by store employees. Spectrum stores are cleaned and disinfected regularly, with frequent cleaning of high-touch areas and hand sanitizer available throughout the store.</p>



<p>The new Spectrum store offers the latest devices and accessories compatible with Spectrum Mobile, which is designed to provide customers the highest quality experience at great value, including access to next-generation 5G service where available. Customers can save up to 40% on a single line with unlimited data compared to other national carriers.<sup>*</sup> They also can bring their own phone or choose from among the latest mobile devices and accessories.</p>



<p>Store visitors also have the opportunity to experience the power of Spectrum Internet, featuring starting speeds of 200 Mbps and plans with connections up to 1 gigabit per second, as well as the interactive Spectrum TV App, which gives customers access to the Spectrum TV<sup>®</sup> content across a wide variety of platforms and devices.</p>



<p>Along with sampling and ordering Spectrum services, customers also can complete a variety of transactions at the store, including account payments and upgrading or exchanging equipment.</p>



<p>Information on <a href="http://link.mediaoutreach.meltwater.com/ls/click?upn=ohOoqyq4IddIafvKtL20lF6PmTFioACx2EOzkvVKvL9ofGVUSU-2FhWp5wEcpc-2BoIOP-YY_dZ5WDwwpW23Ls40NDJ6fruD2V6Rw-2FOWGDRmTRctvDZtdZ1DAvMRyxXCBF62C0bjDHZHTOQoPxiTugC90By7jhYYcvEaI-2FjaK6yljR-2BC-2F-2BsjlNaHfZXF-2BGCMdtQfqo-2BF95exEBHjWjPB-2FCe-2BmNp-2FubEwucqxTqgbp-2F3bvf9vTnG0ZiDusKn9D2vLI1CAEy-2BxBwC134OpxvQQ5ukIy51DEAf5tfM6AzJNidf5vKXWxQicBAGiI0Gq5tKpNXjSM2gsUuJ-2BjB-2F-2BnoNMQ3nZrCHrCRGDSpmOkF1UbG4DSI6YNQXwj-2FGibRk-2FIXWF-2BXgMSZDP3YBeV8r2deHgqXNSSdq2kA3JBTHYGbf8h25kJd9iAoS8BcMJw2MWkue-2FAdqwLPYmiqAP0onwZv7Ae-2BWOOAHaBiA-3D-3D" target="_blank" rel="noreferrer noopener">Spectrum store locations</a> can be found online along with more information about Spectrum products and services. 24-hour customer assistance is always available at <strong>1-855-707-7328</strong>.</p>



<p>*Savings based on HarrisX taxes, fees and surcharges calculation. Visit <a href="http://link.mediaoutreach.meltwater.com/ls/click?upn=ohOoqyq4IddIafvKtL20lF6PmTFioACx2EOzkvVKvL9Nolap2UChvyBla-2BEJxhm2O34j_dZ5WDwwpW23Ls40NDJ6fruD2V6Rw-2FOWGDRmTRctvDZtdZ1DAvMRyxXCBF62C0bjDHZHTOQoPxiTugC90By7jhYYcvEaI-2FjaK6yljR-2BC-2F-2BsjlNaHfZXF-2BGCMdtQfqo-2BF95exEBHjWjPB-2FCe-2BmNp-2FubEwucqxTqgbp-2F3bvf9vTnG0ZiDusKn9D2vLI1CAEy-2BxBwC134OpxvQQ5ukIy51DEAf5tfM6AzJNidf5vKXWxQid0uVjl0zd9UOy7JMIHdSy1WbTZC5oEpwYv591tzjsEcmqeypy92ivUUEXOz2vBrFDsT2-2FNkO4dOR3D3n3M4DCaCLqWznUkRZY6R-2F9j1dJhaKE2MaQjd148gUJ2RydL3-2Ba-2F1Q-2BCce6-2BtUrrfxyydhXzqbVFwfKJUFjH973pV9B9lQ-3D-3D" target="_blank" rel="noreferrer noopener">spectrummobile.com</a> for details.</p>


<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit alignnone amp-wp-e1576f2" data-amp-original-style="text-align:inherit"><amp-ad width="970" height="250" type="doubleclick" data-slot="/21820527880/hm_970x250" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"new-spectrum-store-now-open-in-mount-pleasant","category":["business","news"],"ID":394220}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div>


<hr class="wp-block-separator is-style-wide">


		<div class="wp-block-newspack-blocks-donate wpbnbd tiered">
			<form method="get" action="//racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" target="_top">
				<input type="hidden" name="newspack_donate" value="1">
				<div class="wp-block-newspack-blocks-donate__options">
					<div class="wp-block-newspack-blocks-donate__frequencies frequencies">
						
							<div class="wp-block-newspack-blocks-donate__frequency frequency">
								<input type="radio" value="once" id="newspack-donate-once-71799" name="donation_frequency">
								<label for="newspack-donate-once-71799" class="donation-frequency-label freq-label">
									One-time								</label>

								<div class="wp-block-newspack-blocks-donate__tiers tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="120" id="newspack-tier-once-71799-0">
											<label class="tier-select-label tier-label" for="newspack-tier-once-71799-0">
												$120											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="240" id="newspack-tier-once-71799-1" checked>
											<label class="tier-select-label tier-label" for="newspack-tier-once-71799-1">
												$240											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="600" id="newspack-tier-once-71799-2">
											<label class="tier-select-label tier-label" for="newspack-tier-once-71799-2">
												$600											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_once" value="other" id="newspack-tier-once-71799-other">
										<label class="tier-select-label tier-label" for="newspack-tier-once-71799-other">
											Other										</label>
										<label class="other-donate-label odl" for="newspack-tier-once-71799-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_once_other" value="240" id="newspack-tier-once-71799-other-input">
										</div>
									</div>

								</div>
							</div>
						
							<div class="wp-block-newspack-blocks-donate__frequency frequency">
								<input type="radio" value="month" id="newspack-donate-month-71799" name="donation_frequency" checked>
								<label for="newspack-donate-month-71799" class="donation-frequency-label freq-label">
									Monthly								</label>

								<div class="wp-block-newspack-blocks-donate__tiers tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="10" id="newspack-tier-month-71799-0">
											<label class="tier-select-label tier-label" for="newspack-tier-month-71799-0">
												$10											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="20" id="newspack-tier-month-71799-1" checked>
											<label class="tier-select-label tier-label" for="newspack-tier-month-71799-1">
												$20											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="50" id="newspack-tier-month-71799-2">
											<label class="tier-select-label tier-label" for="newspack-tier-month-71799-2">
												$50											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_month" value="other" id="newspack-tier-month-71799-other">
										<label class="tier-select-label tier-label" for="newspack-tier-month-71799-other">
											Other										</label>
										<label class="other-donate-label odl" for="newspack-tier-month-71799-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_month_other" value="20" id="newspack-tier-month-71799-other-input">
										</div>
									</div>

								</div>
							</div>
						
							<div class="wp-block-newspack-blocks-donate__frequency frequency">
								<input type="radio" value="year" id="newspack-donate-year-71799" name="donation_frequency">
								<label for="newspack-donate-year-71799" class="donation-frequency-label freq-label">
									Annually								</label>

								<div class="wp-block-newspack-blocks-donate__tiers tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="120" id="newspack-tier-year-71799-0">
											<label class="tier-select-label tier-label" for="newspack-tier-year-71799-0">
												$120											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="240" id="newspack-tier-year-71799-1" checked>
											<label class="tier-select-label tier-label" for="newspack-tier-year-71799-1">
												$240											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="600" id="newspack-tier-year-71799-2">
											<label class="tier-select-label tier-label" for="newspack-tier-year-71799-2">
												$600											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_year" value="other" id="newspack-tier-year-71799-other">
										<label class="tier-select-label tier-label" for="newspack-tier-year-71799-other">
											Other										</label>
										<label class="other-donate-label odl" for="newspack-tier-year-71799-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_year_other" value="240" id="newspack-tier-year-71799-other-input">
										</div>
									</div>

								</div>
							</div>
											</div>
				</div>
				<p class="wp-block-newspack-blocks-donate__thanks thanks">
					Your contribution is appreciated.				</p>
				<button type="submit">
					Donate now!				</button>
							</form>
		</div>
		

<div class="wp-block-newspack-blocks-carousel wp-block-newspack-blocks-carousel__autoplay-playing" id="wp-block-newspack-carousel__1"><button aria-label="Pause Slideshow" class="amp-carousel-button-pause amp-carousel-button" on="tap:wp-block-newspack-carousel__amp-carousel__1.toggleAutoplay(toggleOn=false),wp-block-newspack-carousel__1.toggleClass(class=wp-block-newspack-blocks-carousel__autoplay-playing,force=false)"></button><button aria-label="Play Slideshow" class="amp-carousel-button-play amp-carousel-button" on="tap:wp-block-newspack-carousel__amp-carousel__1.toggleAutoplay(toggleOn=true),wp-block-newspack-carousel__1.toggleClass(class=wp-block-newspack-blocks-carousel__autoplay-playing,force=true)"></button><amp-carousel width="4" height="3" layout="responsive" type="slides" data-next-button-aria-label="Next Slide" data-prev-button-aria-label="Previous Slide" controls loop autoplay delay="3000" id="wp-block-newspack-carousel__amp-carousel__1" on="slideChange:wp-block-newspack-carousel__amp-pagination__1.toggle(index=event.index, value=true)" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:75.0000%;"></i-amphtml-sizer>
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" rel="bookmark">
						<amp-img width="1024" height="677" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1024%2C677&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="Spectrum Mount Pleasant" object-fit="cover" layout="fill" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?w=1318&amp;ssl=1 1318w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=300%2C198&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1024%2C677&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1200%2C794&amp;ssl=1 1200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=150%2C99&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=706%2C467&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="677" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?fit=1024%2C677&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="Spectrum Mount Pleasant" loading="lazy" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?w=1318&amp;ssl=1 1318w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=300%2C198&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1024%2C677&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=1200%2C794&amp;ssl=1 1200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=150%2C99&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Mt.-Pleasant-small.jpg?resize=706%2C467&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" rel="bookmark">NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-21T11:48:49-06:00">3 hours ago</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/kenosha-county-covid-19-vaccine-update/" rel="bookmark">
						<amp-img width="1024" height="676" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?fit=1024%2C676&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="covid vaccine" object-fit="cover" layout="fill" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?w=1112&amp;ssl=1 1112w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=300%2C198&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=1024%2C676&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=150%2C99&amp;ssl=1 150w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=706%2C466&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="676" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?fit=1024%2C676&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="covid vaccine" loading="lazy" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?w=1112&amp;ssl=1 1112w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=300%2C198&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=1024%2C676&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=150%2C99&amp;ssl=1 150w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/12/vaccine-covid.jpg?resize=706%2C466&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/kenosha-county-covid-19-vaccine-update/" rel="bookmark">Kenosha County COVID-19 Vaccine Update</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-21T11:10:44-06:00">4 hours ago</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/wisconsin-national-guard-troops-help-ensure-safety-and-security-in-washington-d-c-during-presidential-inauguration/" rel="bookmark">
						<amp-img width="941" height="707" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?fit=941%2C707&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="Wisconsin National Guard" object-fit="cover" layout="fill" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?w=941&amp;ssl=1 941w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=853%2C640&amp;ssl=1 853w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=150%2C113&amp;ssl=1 150w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 941px) 100vw, 941px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="941" height="707" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?fit=941%2C707&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="Wisconsin National Guard" loading="lazy" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?w=941&amp;ssl=1 941w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=853%2C640&amp;ssl=1 853w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=150%2C113&amp;ssl=1 150w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/national-guard.jpg?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 941px) 100vw, 941px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/wisconsin-national-guard-troops-help-ensure-safety-and-security-in-washington-d-c-during-presidential-inauguration/" rel="bookmark">Wisconsin National Guard Troops Help Ensure Safety and Security in Washington D.C. During Presidential Inauguration</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-20T16:33:25-06:00">22 hours ago</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/some-foodshare-households-will-receive-additional-benefits-for-january/" rel="bookmark">
						<amp-img width="995" height="661" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?fit=995%2C661&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="foodshare wisconsin" object-fit="cover" layout="fill" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?w=995&amp;ssl=1 995w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?resize=300%2C199&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?resize=706%2C469&amp;ssl=1 706w" sizes="(max-width: 995px) 100vw, 995px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="995" height="661" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?fit=995%2C661&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="foodshare wisconsin" loading="lazy" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?w=995&amp;ssl=1 995w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?resize=300%2C199&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/grocery.jpg?resize=706%2C469&amp;ssl=1 706w" sizes="(max-width: 995px) 100vw, 995px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/some-foodshare-households-will-receive-additional-benefits-for-january/" rel="bookmark">Some FoodShare Households Will Receive Additional Benefits for January</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-20T15:38:59-06:00">23 hours ago</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/city-of-racine-launches-mortgage-assistance-program-for-homeowners-economically-impacted-by-covid-19/" rel="bookmark">
						<amp-img width="1024" height="684" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?fit=1024%2C684&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="Racine COVId assistance" object-fit="cover" layout="fill" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?w=1107&amp;ssl=1 1107w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=1024%2C684&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=706%2C471&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="684" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?fit=1024%2C684&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="Racine COVId assistance" loading="lazy" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?w=1107&amp;ssl=1 1107w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=1024%2C684&amp;ssl=1 1024w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/09/house.jpg?resize=706%2C471&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/city-of-racine-launches-mortgage-assistance-program-for-homeowners-economically-impacted-by-covid-19/" rel="bookmark">City of Racine Launches Mortgage Assistance Program for Homeowners Economically Impacted by COVID-19</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-20T14:50:01-06:00">January 20th, 2021</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/gov-evers-announces-new-public-health-emergency-issues-new-face-coverings-order-as-state-continues-vaccine-distribution/" rel="bookmark">
						<amp-img width="640" height="427" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?fit=640%2C427&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="Wisconsin COVID" object-fit="cover" layout="fill" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?w=640&amp;ssl=1 640w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?resize=600%2C400&amp;ssl=1 600w" sizes="(max-width: 640px) 100vw, 640px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="640" height="427" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?fit=640%2C427&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="Wisconsin COVID" loading="lazy" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?w=640&amp;ssl=1 640w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/03/tony-evers-2.jpg?resize=600%2C400&amp;ssl=1 600w" sizes="(max-width: 640px) 100vw, 640px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/gov-evers-announces-new-public-health-emergency-issues-new-face-coverings-order-as-state-continues-vaccine-distribution/" rel="bookmark">Gov. Evers Announces New Public Health Emergency, Issues New Face Coverings Order as State Continues Vaccine Distribution</a></h3>
					<div class="entry-meta">
						<amp-img src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://secure.gravatar.com/avatar/992b81fd0348eeb168d8eb3d77c24a89?s=96&amp;d=mm&amp;r=g" width="96" height="96" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/racine-county-eye-staff/">Racine County Eye</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-20T11:41:54-06:00">January 20th, 2021</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			
			<article class="post-has-image">
				<figure class="post-thumbnail">
					<a href="https://racinecountyeye.com/inauguration-day-2021-what-to-expect-and-whats-happening/" rel="bookmark">
						<amp-img width="1024" height="541" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?fit=1024%2C541&amp;ssl=1" class="attachment-large size-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-fill i-amphtml-layout-size-defined" alt="Capitol, inaguration Day" object-fit="cover" layout="fill" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=300%2C158&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=1024%2C541&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=1200%2C634&amp;ssl=1 1200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=150%2C79&amp;ssl=1 150w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=706%2C373&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px" disable-inline-width="" i-amphtml-layout="fill"><noscript><img width="1024" height="541" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?fit=1024%2C541&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="Capitol, inaguration Day" loading="lazy" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=300%2C158&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=1024%2C541&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=1200%2C634&amp;ssl=1 1200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=150%2C79&amp;ssl=1 150w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2021/01/Untitled-design-84.png?resize=706%2C373&amp;ssl=1 706w" sizes="(max-width: 1024px) 100vw, 1024px"></noscript></amp-img>					</a>
				</figure>
				<div class="entry-wrapper">

				
					<h3 class="entry-title"><a href="https://racinecountyeye.com/inauguration-day-2021-what-to-expect-and-whats-happening/" rel="bookmark">Inauguration Day 2021: What to expect and what’s happening</a></h3>
					<div class="entry-meta">
						<amp-img src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2014/01/denise.jpg?resize=96%2C96&amp;ssl=1" width="96" height="96" alt="Denise Lockwood" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Jzk2JyB3aWR0aD0nOTYnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img loading="lazy" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2014/01/denise.jpg?resize=96%2C96&amp;ssl=1" width="96" height="96" alt="Denise Lockwood" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo"></noscript></amp-img>								<span class="byline">
									by <span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/denise/">Denise Lockwood</a></span>								</span><!-- .author-name -->
								<time class="entry-date published" datetime="2021-01-20T09:21:38-06:00">January 20th, 2021</time>					</div><!-- .entry-meta -->
				</div><!-- .entry-wrapper -->
			</article>
			</amp-carousel><amp-selector id="wp-block-newspack-carousel__amp-pagination__1" class="swiper-pagination-bullets amp-pagination i-amphtml-layout-container" on="select:wp-block-newspack-carousel__amp-carousel__1.goToSlide(index=event.targetOption)" layout="container" i-amphtml-layout="container"><button option="0" class="swiper-pagination-bullet" aria-label="Go to slide 1" selected></button><button option="1" class="swiper-pagination-bullet" aria-label="Go to slide 2"></button><button option="2" class="swiper-pagination-bullet" aria-label="Go to slide 3"></button><button option="3" class="swiper-pagination-bullet" aria-label="Go to slide 4"></button><button option="4" class="swiper-pagination-bullet" aria-label="Go to slide 5"></button><button option="5" class="swiper-pagination-bullet" aria-label="Go to slide 6"></button><button option="6" class="swiper-pagination-bullet" aria-label="Go to slide 7"></button></amp-selector></div>

<div class="wp-block-newspack-blocks-wp-block-newspack-ads-blocks-ad-unit alignnone amp-wp-e1576f2" data-amp-original-style="text-align:inherit"><amp-ad width="970" height="250" type="doubleclick" data-slot="/21820527880/hm_970x250" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"new-spectrum-store-now-open-in-mount-pleasant","category":["business","news"],"ID":394220}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div>
<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-6009e915766e2" aria-labelledby="related-posts-item-6009e915766e2-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6009e915766e2-label" href="https://racinecountyeye.com/ulta-beauty-opening-in-mount-pleasant/">BREAKING: ULTA Beauty Opening in Mount Pleasant</a></li><li class="jp-related-posts-i2__post-date">March 10th, 2015</li><li class="jp-related-posts-i2__post-context">In "Business"</li></ul><ul id="related-posts-item-6009e9157670c" aria-labelledby="related-posts-item-6009e9157670c-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6009e9157670c-label" href="https://racinecountyeye.com/festival-foods-breaks-ground/">Festival Foods 'Breaks Ground' for Dec. Opening</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://racinecountyeye.com/festival-foods-breaks-ground/"><amp-img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2014/09/FestivalFoodsGroundBreaking.jpg?fit=500%2C375&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2014/09/FestivalFoodsGroundBreaking.jpg?fit=500%2C375&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">September 6th, 2014</li><li class="jp-related-posts-i2__post-context">In "Business"</li></ul><ul id="related-posts-item-6009e91576734" aria-labelledby="related-posts-item-6009e91576734-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-6009e91576734-label" href="https://racinecountyeye.com/you-asked-mount-pleasant-trustee-candidates-answer/">You Asked, Mount Pleasant Trustee Candidates Answer</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://racinecountyeye.com/you-asked-mount-pleasant-trustee-candidates-answer/"><amp-img src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2013/11/Screen-Shot-2013-11-22-at-1.33.50-PM.png?fit=790%2C567&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Mount Pleasant Developer" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2013/11/Screen-Shot-2013-11-22-at-1.33.50-PM.png?fit=790%2C567&amp;ssl=1&amp;resize=350%2C200" width="350" alt="Mount Pleasant Developer" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">April 4th, 2015</li><li class="jp-related-posts-i2__post-context">In "Elections"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://racinecountyeye.com/tag/mount-pleasant/" rel="tag">Mount Pleasant</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/spectrum/" rel="tag">Spectrum</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/spectrum-mount-pleasant/" rel="tag">Spectrum Mount Pleasant</a></span>	</footer><!-- .entry-footer -->

	
</article><!-- #post-${ID} -->
				</div>

			
		</main><!-- #main -->
	</section><!-- #primary -->


				<div class="newspack_global_ad global_above_footer">
								<div id="div-gpt-amp-ht_728x90-6009e915773f2-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/ht_728x90" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"new-spectrum-store-now-open-in-mount-pleasant","category":["business","news"],"ID":394220}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div>			</div>
			
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://racinecountyeye.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE2OScgd2lkdGg9JzIwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-icons-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			
<amp-consent id="eu-cookie-consent" layout="nodisplay" class="widget widget_eu_cookie_law_widget i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
	<script type="application/json">
		{
			"consentInstanceId": "eu-cookie-consent",
			"consentRequired": true,
			"promptUI": "eu-cookie-consent-prompt"
		}
	</script>
	<div class="popupOverlay" id="eu-cookie-consent-prompt">
		<div class="consentPopup" id="eu-cookie-law">
			<form method="get" action="//racinecountyeye.com/new-spectrum-store-now-open-in-mount-pleasant/" target="_top">
				<input type="button" on="tap:eu-cookie-consent.accept" class="accept" value="Close and accept" role="button" tabindex="0">
			</form>
			Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br>
To find out more, including how to control cookies, see here:			<a href="https://racinecountyeye.com/terms-conditions/" rel="">
				Cookie Policy			</a>
		</div>
	</div>
</amp-consent>
		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

				<aside class="widget-area" role="complementary" aria-label="Below Footer">
		<div class="wrapper">
			<section id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widget-title">Copyright</h2><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-29815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29815"><a href="https://racinecountyeye.com/about/">About</a></li>
<li id="menu-item-29816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29816"><a href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/">Grow your business with the Racine County Eye and the Kenosha Lens</a></li>
<li id="menu-item-29817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29817"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-354317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-354317"><a href="https://www.racinecountyeye.com/privacy-policy/">Privacy policy</a></li>
</ul></div></section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->

			<div class="wrapper site-info-contain">
													<span class="copyright">© 2021 Local News I Racine County Eye - Racine, Wisconsin.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

				<a class="privacy-policy-link" href="https://racinecountyeye.com/terms-conditions/">Terms &amp; Conditions</a>			</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->


			<amp-analytics type="gtag" config='https://racinecountyeye.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=394220&amp;custom_dimensions=[{"role":"category","option":{"value":"category","label":"Category"},"gaID":"ga:dimension2"}]&amp;custom_dimensions_existing_values={"dimension2":"news"}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-analytics>
		

<!-- START Parse.ly Include: Standard -->



<!-- END Parse.ly Include: Standard -->
		
			<div data-amp-original-style="display:none" class="amp-wp-cb45893">
	<div class="grofile-hash-map-992b81fd0348eeb168d8eb3d77c24a89">
	</div>
	<div class="grofile-hash-map-992b81fd0348eeb168d8eb3d77c24a89">
	</div>
	<div class="grofile-hash-map-8774d6416866e8864e8e110377e97853">
	</div>
	</div>
			<!-- Facebook Pixel Code -->
			<!--noscript-->
				<amp-img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" class="amp-wp-enforced-sizes amp-wp-6a19fc1 i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" data-amp-original-style="display:inline-block" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzEnIHdpZHRoPScxJyB4bWxucz0naHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmcnIHZlcnNpb249JzEuMScvPg=="></i-amphtml-sizer><noscript><img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" data-amp-original-style="display:none" class="amp-wp-cb45893"></noscript></amp-img>
			<!--/noscript-->
			<!-- End Facebook Pixel Code -->
					<amp-install-serviceworker src="https://racinecountyeye.com/wp.serviceworker" data-iframe-src="https://racinecountyeye.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-128295961-1","config":{"UA-128295961-1":{"groups":"default","linker":[],"send_page_view":false,"dimension2":"news"}}},"triggers":{"socialShareClickedFacebook":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"facebook","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"facebook\"]"},"socialShareClickedTwitter":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"twitter","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"twitter\"]"},"socialShareClickedWhatsApp":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"whatsapp","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"whatsapp\"]"},"socialShareClickedLinkedIn":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"linkedin","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"linkedin\"]"},"articleRead25":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":25},"event_value":25,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[25]}},"articleRead50":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":50},"event_value":50,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[50]}},"articleRead100":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":100},"event_value":100,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[100]}}}}</script></amp-analytics>
<!-- Google Tag Manager added by Site Kit -->
<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-P7DVBXQ" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>
<!-- End Google Tag Manager -->
<amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"racinecountyeye.com"}}</script></amp-analytics>	
	
















































































			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-128295961-1","config":{"UA-128295961-1":{"groups":"default","linker":[],"send_page_view":false,"dimension2":"news"}}},"triggers":{"socialShareClickedFacebook":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"facebook","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"facebook\"]"},"socialShareClickedTwitter":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"twitter","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"twitter\"]"},"socialShareClickedWhatsApp":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"whatsapp","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"whatsapp\"]"},"socialShareClickedLinkedIn":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"linkedin","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"linkedin\"]"},"articleRead25":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":25},"event_value":25,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[25]}},"articleRead50":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":50},"event_value":50,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[50]}},"articleRead100":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_label":"NEW SPECTRUM STORE NOW OPEN IN MOUNT PLEASANT","event_category":"NTG article milestone","non_interaction":true,"value":100},"event_value":100,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[100]}}}}</script></amp-analytics>
<!-- Google Tag Manager added by Site Kit -->
<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-P7DVBXQ" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension"}</script></amp-analytics>
<!-- End Google Tag Manager -->
	<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A9.3.2&amp;blog=172500100&amp;post=394220&amp;tz=-6&amp;srv=racinecountyeye.com&amp;host=racinecountyeye.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 96 seconds ago
	generated in 1.311 seconds
	served from batcache in 0.003 seconds
	expires in 204 seconds
-->
