<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012005151844001">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="google-site-verification" content="TAth4vGpZLIsu4GRdUzOD0-_kO6THbfE3G4NAPTNNH4"><meta name="robots" content="index, follow"><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="One person injured in Mount Pleasant crash | Local News I Racine County Eye - Racine, Wisconsin"><meta property="og:description" content="Click here to buy Click here to buy! I'm not interested MOUNT PLEASANT, WI – A male passenger was rendered unconscious Thursday afternoon when a Lexus crashed into the car […]"><meta property="og:url" content="https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/"><meta property="og:site_name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta property="article:publisher" content="https://www.facebook.com/racinecountyeye"><meta property="article:published_time" content="2020-05-29T12:31:19+00:00"><meta property="article:modified_time" content="2020-05-29T12:31:32+00:00"><meta property="og:image" content="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?fit=725%2C544&amp;ssl=1"><meta property="og:image:width" content="725"><meta property="og:image:height" content="544"><meta property="fb:app_id" content="482509548893527"><meta name="twitter:card" content="summary"><meta name="twitter:creator" content="@racinecountyeye"><meta name="twitter:site" content="@racinecountyeye"><meta name="generator" content="Site Kit by Google 1.8.1"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="application-name" content="Local News I Racine County Eye - Racine, Wisconsin"><meta name="et-api-version" content="v1"><meta name="et-api-origin" content="https://racinecountyeye.com"><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://racinecountyeye.com"><meta name="generator" content="AMP Plugin v1.5.3; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=270%2C270&amp;ssl=1"><title>One person injured in Mount Pleasant crash | Local News I Racine County Eye - Racine, Wisconsin</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//secure.gravatar.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//v0.wordpress.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-animation-0.1.js" async custom-element="amp-animation"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" async custom-element="amp-bind"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-lightbox-gallery-0.1.js" async="" custom-element="amp-lightbox-gallery"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-position-observer-0.1.js" async custom-element="amp-position-observer"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-joseph-fonts-css" href="https://fonts.googleapis.com/css?family=Old+Standard+TT%3A400%2C400i%2C700%7CEB+Garamond%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- Jetpack Site Verification Tags --><!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://racinecountyeye.com/#website","url":"https://racinecountyeye.com/","name":"Racine County Eye","description":"","potentialAction":[{"@type":"SearchAction","target":"https://racinecountyeye.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?fit=725%2C544&ssl=1","width":725,"height":544,"caption":"Authorities say the Wisconsin State Patrol and South Shore Fire Department helped to clear the accident scene. (Scott Anderson, Patch Staff)"},{"@type":"WebPage","@id":"https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/#webpage","url":"https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/","name":"One person injured in Mount Pleasant crash | Local News I Racine County Eye - Racine, Wisconsin","isPartOf":{"@id":"https://racinecountyeye.com/#website"},"primaryImageOfPage":{"@id":"https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/#primaryimage"},"datePublished":"2020-05-29T12:31:19+00:00","dateModified":"2020-05-29T12:31:32+00:00","author":{"@id":"https://racinecountyeye.com/#/schema/person/1c41b692d31f0761bd59c38fc84002e6"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/"]}]},{"@type":["Person"],"@id":"https://racinecountyeye.com/#/schema/person/1c41b692d31f0761bd59c38fc84002e6","name":"Mark Lisowski","image":{"@type":"ImageObject","@id":"https://racinecountyeye.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/29efedfcd2683140ac59e4e397964012?s=96&d=mm&r=g","caption":"Mark Lisowski"}}]}</script><!-- / Yoast SEO plugin. --><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Feed" href="https://racinecountyeye.com/feed/"><link rel="alternate" type="application/rss+xml" title="Local News I Racine County Eye - Racine, Wisconsin » Comments Feed" href="https://racinecountyeye.com/comments/feed/"><link rel="alternate" type="text/calendar" title="Local News I Racine County Eye - Racine, Wisconsin » iCal Feed" href="https://racinecountyeye.com/calendar/?ical=1"><link rel="https://api.w.org/" href="https://racinecountyeye.com/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://racinecountyeye.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://racinecountyeye.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/pbFN9G-1zRX"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fone-person-injured-in-mount-pleasant-crash%2F"><link rel="alternate" type="text/xml+oembed" href="https://racinecountyeye.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fracinecountyeye.com%2Fone-person-injured-in-mount-pleasant-crash%2F&amp;format=xml"><script id="amp-access" type="application/json">
				[{"namespace":"popup_376104","authorization":"https:\/\/racinecountyeye.com\/wp-json\/newspack-popups\/v1\/reader?popup_id=376104&rid=READER_ID&url=CANONICAL_URL&RANDOM","noPingback":true,"authorizationFallbackResponse":{"displayPopup":false}}]			</script><link rel="manifest" href="https://racinecountyeye.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=192%2C192&amp;ssl=1"><link rel="https://theeventscalendar.com/" href="https://racinecountyeye.com/wp-json/tribe/tickets/v1/"><link rel="https://theeventscalendar.com/" href="https://racinecountyeye.com/wp-json/tribe/events/v1/"><!--noscript--><!--/noscript--><!-- WooCommerce Facebook Integration Begin --><!-- WooCommerce Facebook Integration End --><link rel="apple-touch-icon" href="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1.png?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template-default single single-post postid-376213 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js tribe-no-js page-template-srv-htdocs-wp-content-themes-newspack-theme-page-php tribe-theme-parent-newspack-theme tribe-theme-child-newspack-joseph tribe-events-filter-view tribe-filters-closed tribe-filters-vertical tribe-filters-live-update singular hide-homepage-title hide-site-tagline h-nsub h-sb h-ll h-dh has-sidebar has-featured-image single-featured-image-beside has-large-featured-image categories-hidden tags-hidden">
		<div class="newspack_global_ad global_above_header">
			<div id="div-gpt-amp-em_728x90-5ed10ce95a561-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/em_728x90" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> 
		</div>
			<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav toolbar="(min-width: 767px)" toolbar-target="site-navigation" class="main-navigation nav1" aria-label="Top Menu">
		<ul id="menu-main-navigation" class="main-menu"><li id="menu-item-375417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-375417"><a href="https://racinecountyeye.com">HOME</a></li>
<li id="menu-item-363246" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-363246"><a href="https://racinecountyeye.com/category/news/" aria-haspopup="true" aria-expanded="false">NEWS</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363247"><a href="https://racinecountyeye.com/category/news/business/">Business</a></li>
	<li id="menu-item-29809" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29809"><a href="https://racinecountyeye.com/category/news/police-and-fire/">Police &amp; Fire</a></li>
	<li id="menu-item-363250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363250"><a href="https://racinecountyeye.com/category/news/government/">Government</a></li>
	<li id="menu-item-363253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363253"><a href="https://racinecountyeye.com/category/news/government/politics/elections/">Elections</a></li>
	<li id="menu-item-372718" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-372718"><a href="https://racinecountyeye.com/election-guide-2020/">Election Guide 2020</a></li>
	<li id="menu-item-363254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363254"><a href="https://racinecountyeye.com/category/news/edu/">Schools</a></li>
	<li id="menu-item-363255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363255"><a href="https://racinecountyeye.com/category/news/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-363258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363258"><a href="https://racinecountyeye.com/category/community/" aria-haspopup="true" aria-expanded="false">COMMUNITY</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-370402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370402"><a href="https://racinecountyeye.com/category/community/real-estate/" aria-haspopup="true" aria-expanded="false">Real Estate</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-371182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371182"><a href="https://racinecountyeye.com/category/community/real-estate/homes-for-sale/">Homes for Sale</a></li>
		<li id="menu-item-371183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371183"><a href="https://racinecountyeye.com/category/community/real-estate/apartments-for-rent/">Apartments for Rent</a></li>
		<li id="menu-item-371184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371184"><a href="https://racinecountyeye.com/category/community/real-estate/property-transfers/">Property Transfers</a></li>
		<li id="menu-item-371181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-371181"><a href="https://racinecountyeye.com/category/community/real-estate/finances/">Finances</a></li>
	</ul>
</li>
	<li id="menu-item-365272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365272"><a href="https://racinecountyeye.com/category/community/public-notices/">Public Notices</a></li>
	<li id="menu-item-29811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29811"><a href="https://racinecountyeye.com/category/community/obituaries/">Obituaries</a></li>
	<li id="menu-item-363260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363260"><a href="https://racinecountyeye.com/category/community/opinion/">Opinion</a></li>
	<li id="menu-item-367754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-367754"><a href="https://racinecountyeye.com/category/community/non-profits/">Non-Profits</a></li>
	<li id="menu-item-370411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370411"><a href="https://racinecountyeye.com/category/community/pets/">Pets</a></li>
</ul>
</li>
<li id="menu-item-363264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363264"><a href="https://racinecountyeye.com/category/culture/" aria-haspopup="true" aria-expanded="false">CULTURE</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-363265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363265"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/" aria-haspopup="true" aria-expanded="false">Arts &amp; Entertainment</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-363266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363266"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/comic/">Comic</a></li>
		<li id="menu-item-363267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363267"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/movie-reviews/">Movie reviews</a></li>
		<li id="menu-item-363268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363268"><a href="https://racinecountyeye.com/category/culture/arts-entertainment/quick-spins/">Quick Spins</a></li>
	</ul>
</li>
	<li id="menu-item-363269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363269"><a href="https://racinecountyeye.com/category/culture/food-drinks/">Food &amp; Drinks</a></li>
	<li id="menu-item-363271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-363271"><a href="https://racinecountyeye.com/category/culture/shopping/">Shopping</a></li>
	<li id="menu-item-363272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-363272"><a href="https://racinecountyeye.com/category/culture/sports-recreation/" aria-haspopup="true" aria-expanded="false">Sports &amp; Recreation</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
	<ul class="sub-menu">
		<li id="menu-item-364976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-364976"><a href="https://racinecountyeye.com/category/culture/sports-recreation/esports/">ESports</a></li>
	</ul>
</li>
	<li id="menu-item-365086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-365086"><a href="https://racinecountyeye.com/category/culture/things-to-do/">Things To Do</a></li>
</ul>
</li>
<li id="menu-item-370403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-370403"><a href="https://racinecountyeye.com/category/eye-employment/" aria-haspopup="true" aria-expanded="false">EMPLOYMENT</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-370404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370404"><a href="https://racinecountyeye.com/category/eye-employment/business-spotlight/">Business Spotlight</a></li>
	<li id="menu-item-370405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370405"><a href="https://racinecountyeye.com/category/eye-employment/eye-on-talent/">Eye on Talent</a></li>
	<li id="menu-item-370406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370406"><a href="https://racinecountyeye.com/category/eye-employment/resources/">Resources</a></li>
	<li id="menu-item-370410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370410"><a href="https://racinecountyeye.com/category/eye-employment/jobs/">Jobs</a></li>
	<li id="menu-item-370408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370408"><a href="https://racinecountyeye.com/category/community/real-estate/finances/">Finances</a></li>
</ul>
</li>
<li id="menu-item-78714" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78714"><a href="http://racinecountyeye.com/calendar">CALENDAR</a></li>
<li id="menu-item-367628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-367628"><a href="https://www.racinecountyeye.com/racine-and-kenosha-county-nonprofits/">NONPROFITS</a></li>
<li id="menu-item-370533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-370533"><a href="https://racinecountyeye.com/category/celebrations/">CELEBRATIONS</a></li>
<li id="menu-item-372792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-372792"><a href="https://racinecountyeye.com/category/coronavirus/">CORONAVIRUS</a></li>
</ul>	</nav>
	<nav class="secondary-menu nav2" aria-label="Secondary Menu" toolbar-target="secondary-nav-contain" toolbar="(min-width: 767px)">
		<ul id="menu-secondary" class="secondary-menu"><li id="menu-item-3426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3426"><a rel="httpsracinecountyeyecomgrow-business-low-cost-advertising-solutions" href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/">Grow Your Business</a></li>
<li id="menu-item-2530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2530"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-370412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-370412"><a href="https://racinecountyeye.com/support-our-publication/">Support our publication</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-icons" class="social-links-menu"><li id="menu-item-29805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li id="menu-item-29806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-29807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li id="menu-item-29808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

		
							<div class="top-header-contain desktop-only">
					<div class="wrapper">
						
						<div id="secondary-nav-contain">
													</div>

													<div id="social-nav-contain">
															</div>
											</div><!-- .wrapper -->
				</div><!-- .top-header-contain -->
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
					
					
					<div class="site-branding">

	
		<a href="https://racinecountyeye.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;169&quot; width=&quot;200&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="200" height="169" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?fit=200%2C169&amp;ssl=1" class="custom-logo" alt="Local News I Racine County Eye – Racine, Wisconsin" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?w=200&amp;ssl=1 200w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2017/03/RCE-Web-Logo_transparent-background-1-e1488582236368.png?resize=600%2C507&amp;ssl=1 600w" sizes="(max-width: 200px) 100vw, 200px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://racinecountyeye.com/" rel="home">Local News I Racine County Eye – Racine, Wisconsin</a></p>
					
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

											</div><!-- .nav-wrapper -->

											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							Menu						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://racinecountyeye.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
			<div class="newspack_global_ad global_below_header">
			<div id="div-gpt-amp-et_728x90-5ed10ce96b706-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/et_728x90" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> 
		</div>
		
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-news category-police-and-fire tag-crash tag-mount-pleasant tag-wisconsin">
		<main id="main" class="site-main">

			
	<div class="featured-image-beside">
		<div class="wrapper">
			<header class="entry-header">
				

	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://racinecountyeye.com/category/news/" rel="category tag">News</a></span>		<h1 class="entry-title ">
		One person injured in Mount Pleasant crash	</h1>
	
	<div class="entry-subhead">
		<div class="entry-meta">
			<span class="author-avatar"><amp-img src="https://secure.gravatar.com/avatar/29efedfcd2683140ac59e4e397964012?s=80&amp;d=mm&amp;r=g" width="80" height="80" alt="Avatar" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 photo avatar-default amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;80&quot; width=&quot;80&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://secure.gravatar.com/avatar/29efedfcd2683140ac59e4e397964012?s=80&amp;d=mm&amp;r=g" width="80" height="80" alt="Avatar" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 photo avatar-default"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://racinecountyeye.com/author/mark-lisowski/">Mark Lisowski</a></span> 			</span><!-- .byline -->
					<span class="posted-on"><time class="entry-date published" datetime="2020-05-29T07:31:19-05:00">May 29, 2020</time><time class="updated" datetime="2020-05-29T07:31:32-05:00">May 29, 2020</time></span>		</div><!-- .meta-info -->
		<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
			</header>
		</div><!-- .wrapper -->

		
			<figure class="post-thumbnail">

				<amp-img width="725" height="544" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?fit=725%2C544&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Three-car crash, Mount Pleasant, Wisconsin" object-fit="cover" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?w=725&amp;ssl=1 725w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=80%2C60&amp;ssl=1 80w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;544&quot; width=&quot;725&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="725" height="544" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?fit=725%2C544&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="Three-car crash, Mount Pleasant, Wisconsin" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?w=725&amp;ssl=1 725w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=80%2C60&amp;ssl=1 80w" sizes="(max-width: 725px) 100vw, 725px"></noscript></amp-img>
			</figure><!-- .post-thumbnail -->

		
					<figcaption><span>Authorities say the Wisconsin State Patrol and South Shore Fire Department helped to clear the accident scene. (Scott Anderson, Patch Staff) </span></figcaption>
			</div><!-- .featured-image-behind -->

				<div class="main-content">

					<section id="newspack-ads-widget-2" class="above-content widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="728" height="90" type="doubleclick" data-slot="/21820527880/em_728x90" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div></section>
<article id="post-376213" class="post-376213 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-police-and-fire tag-crash tag-mount-pleasant tag-wisconsin entry">
	<div class="entry-content">
				<amp-layout amp-access="popup_376104.displayPopup" amp-access-hide class="newspack-lightbox newspack-lightbox-placement-bottom  i-amphtml-layout-container" role="button" tabindex="0" id="lightbox336077413" i-amphtml-layout="container">
			<div class="newspack-popup-wrapper amp-wp-80cd2d3" data-amp-original-style="background-color:#000000;color:#fff">
				<div class="newspack-popup">
										
<p class="has-huge-font-size"><a href="https://racinecountyeye.com/racine-county-eye-gear/?_gl=1*643v9m*_ga*NDU0MjM1NzMyLjE1NzY0NjA1Nzc&amp;fbclid=IwAR2GlWlv4iSmJQjXPf2i5zOzijyaQR62kziACopv9_9oDNsrklRjk51pSYk" data-type="https://racinecountyeye.com/racine-county-eye-gear/?_gl=1*643v9m*_ga*NDU0MjM1NzMyLjE1NzY0NjA1Nzc&amp;fbclid=IwAR2GlWlv4iSmJQjXPf2i5zOzijyaQR62kziACopv9_9oDNsrklRjk51pSYk">Click here to buy</a></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?fit=960%2C720&amp;ssl=1" alt="" data-amp-lightbox="true" lightbox="true" class="wp-image-376105 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1024%2C768&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1200%2C900&amp;ssl=1 1200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1044%2C783&amp;ssl=1 1044w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=632%2C474&amp;ssl=1 632w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=536%2C402&amp;ssl=1 536w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=706%2C530&amp;ssl=1 706w" width="960" height="720" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;720&quot; width=&quot;960&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?fit=960%2C720&amp;ssl=1" alt="" class="wp-image-376105" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1024%2C768&amp;ssl=1 1024w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1200%2C900&amp;ssl=1 1200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=1044%2C783&amp;ssl=1 1044w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=632%2C474&amp;ssl=1 632w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=536%2C402&amp;ssl=1 536w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Add-a-heading-8.png?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 960px) 100vw, 960px" width="960" height="720"></noscript></amp-img><figcaption>Click here to buy!</figcaption></figure>
										<form class="popup-not-interested-form popup-action-form" method="POST" action-xhr="https://racinecountyeye.com/wp-json/newspack-popups/v1/reader" target="_top">
								<input name="url" type="hidden" value="CANONICAL_URL" data-amp-replace="CANONICAL_URL">
		<input name="popup_id" type="hidden" value="376104">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
								<input name="suppress_forever" type="hidden" value="1">
						<button on="tap:lightbox336077413.hide" aria-label="" data-amp-original-style="background-color:#000000;color:#fff" class="amp-wp-80cd2d3">I'm not interested</button>
					</form>
										<form class="popup-dismiss-form popup-action-form" method="POST" action-xhr="https://racinecountyeye.com/wp-json/newspack-popups/v1/reader" target="_top">
								<input name="url" type="hidden" value="CANONICAL_URL" data-amp-replace="CANONICAL_URL">
		<input name="popup_id" type="hidden" value="376104">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
								<button on="tap:lightbox336077413.hide" class="newspack-lightbox__close amp-wp-80cd2d3" aria-label="Close Pop-up" data-amp-original-style="background-color:#000000;color:#fff">
							<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewbox="0 0 24 24" role="img" aria-hidden="true" focusable="false"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12 19 6.41z"></path></svg>
						</button>
					</form>
				</div>
			</div>
			<form class="popup-dismiss-form popup-action-form" method="POST" action-xhr="https://racinecountyeye.com/wp-json/newspack-popups/v1/reader" target="_top">
						<input name="url" type="hidden" value="CANONICAL_URL" data-amp-replace="CANONICAL_URL">
		<input name="popup_id" type="hidden" value="376104">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status">
						<button class="newspack-lightbox-shim amp-wp-cb2a876" on="tap:lightbox336077413.hide" data-amp-original-style="opacity: 0.3;background-color:#000000;"></button>
			</form>
		</amp-layout>
		<div id="newspack-lightbox-marker">
			<amp-position-observer on="enter:showAnim.start;" once layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay"></amp-position-observer>
		</div>
		<amp-animation id="showAnim" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
			<script type="application/json">
				{
					"duration": "125ms",
					"fill": "both",
					"iterations": "1",
					"direction": "alternate",
					"animations": [
						{
							"selector": ".newspack-lightbox",
							"delay": "5500",
							"keyframes": {
								"opacity": ["0", "1"],
								"visibility": ["hidden", "visible"]
							}
						},
						{
							"selector": ".newspack-lightbox",
							"delay": "5000",
							"keyframes": {
								"transform": ["translateY(100vh)", "translateY(0vh)"]
							}
						},
						{
								"selector": ".newspack-popup-wrapper",
								"delay": "5625",
								"keyframes": {
																			"transform": ["translateY(100%)", "translateY(0)"]
																	}
						}
					]
				}
			</script>
		</amp-animation>
				<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{
					"vars" : {
						"gtag_id": "UA-128295961-1",
						"config" : {
							"UA-128295961-1": { "groups": "default", "send_page_view": false }
						}
					},
					"triggers": {
												"popupAnchorClicks": {
							"selector": "#lightbox336077413 a",
							"on": "click",
							"request": "event",
							"vars": {
								"event_name": "Link Click",
								"event_label": "Newspack Announcement: We need your support (376104)",
								"event_category": "Newspack Announcement"
							}
						},
																									"popupDismissed": {
								"on": "amp-form-submit-success",
								"request": "event",
								"selector": "#lightbox336077413 form.popup-dismiss-form",
								"vars": {
									"event_name": "Dismissal",
									"event_label": "Newspack Announcement: We need your support (376104)",
									"event_category": "Newspack Announcement"
								}
							},
																		"popupNotInterested": {
							"on": "amp-form-submit-success",
							"request": "event",
							"selector": "#lightbox336077413 form.popup-not-interested-form",
							"vars": {
								"event_name": "Permanent Dismissal",
								"event_label": "Newspack Announcement: We need your support (376104)",
								"event_category": "Newspack Announcement"
							}
						},
												"popupVisible": {
							"on": "visible",
							"request": "event",
							"selector": "#lightbox336077413",
							"visibilitySpec": {
								"totalTimeMin": "500"
							},
							"vars": {
								"event_name": "Seen",
								"event_label": "Newspack Announcement: We need your support (376104)",
								"event_category": "Newspack Announcement"
							}
						},
						"popupPageLoaded": {
							"on": "ini-load",
							"selector": "#lightbox336077413",
							"request": "event",
							"vars": {
								"event_name": "Load",
								"event_label": "Newspack Announcement: We need your support (376104)",
								"event_category": "Newspack Announcement"
							}
						}
					}
				}
			</script>
		</amp-analytics>

		
						
<p>MOUNT PLEASANT, WI – A male passenger was rendered unconscious Thursday afternoon when a Lexus crashed into the car he was driving.</p>



<p><a rel="noreferrer noopener" target="_blank" href="https://www.mtpleasantwi.gov/187/Police-Department">Mount Pleasant police</a> and the <a rel="noreferrer noopener" target="_blank" href="https://www.mtpleasantwi.gov/196/South-Shore-Fire-Department">South Shore Fire Department</a> responded to a car crash with injuries near Washington Avenue and Meadowlane Avenue around 2:30 p.m. The unconscious passenger of a 2003 Toyota Camry was recovered from the backseat and transported to the <a href="https://www.getascensionwisconsincare.com/?keyword=%2Bascension%20%2Ball%20%2Bsaints&amp;gclid=CjwKCAjw5cL2BRASEiwAENqAPpiKJGYVp9EJXYbCf5w5kqaXb3_MM1PHpqybr8UEGA0W5hsr4D6myxoCzaYQAvD_BwE">Ascension-All Saints</a> emergency room with serious but non-life-threatening injuries. Another female passenger in the Camry was also transported with minor injuries.</p>



<p>The Wisconsin State Patrol conducted a crash reconstruction at the scene due to the severity of the injuries. The 2011 Lexus had major front-end damage while the Toyota sustained major side damage. State Highway 20 was shut down for the period of the crash reconstruction and reopened afterward.</p>



<div class="wp-block-group newspack-pattern donation__style-2"><div class="wp-block-group__inner-container">
<h2 class="has-text-align-center">Support our publication</h2>



<div class="wp-block-columns">
<div class="wp-block-column amp-wp-4d8e209" data-amp-original-style="flex-basis:33.33%">
<p>With the support of readers like you, we provide thoughtfully researched articles for a more informed and connected community. This is your chance to support credible, community-based, public-service journalism. Please join us!</p>
</div>



<div class="wp-block-column amp-wp-86a7827" data-amp-original-style="flex-basis:66.66%">		<div class="wp-block-newspack-blocks-donate wpbnbd tiered">
			<form method="get" action="//racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/" target="_top">
				<input type="hidden" name="newspack_donate" value="1">
				<div class="wp-block-newspack-blocks-donate__options">
					<div class="wp-block-newspack-blocks-donate__frequencies">
						
							<div class="wp-block-newspack-blocks-donate__frequency">
								<input type="radio" value="once" id="newspack-donate-once-1462696087" name="donation_frequency">
								<label for="newspack-donate-once-1462696087" class="donation-frequency-label">
									One-time								</label>

								<div class="wp-block-newspack-blocks-donate__tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="60" id="newspack-tier-once-1462696087-0">
											<label class="tier-select-label" for="newspack-tier-once-1462696087-0">
												$60											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="120" id="newspack-tier-once-1462696087-1" checked>
											<label class="tier-select-label" for="newspack-tier-once-1462696087-1">
												$120											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_once" value="600" id="newspack-tier-once-1462696087-2">
											<label class="tier-select-label" for="newspack-tier-once-1462696087-2">
												$600											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_once" value="other" id="newspack-tier-once-1462696087-other">
										<label class="tier-select-label" for="newspack-tier-once-1462696087-other">
											Other										</label>
										<label class="other-donate-label" for="newspack-tier-once-1462696087-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_once_other" value="120" id="newspack-tier-once-1462696087-other-input">
										</div>
									</div>

								</div>
							</div>
						
							<div class="wp-block-newspack-blocks-donate__frequency">
								<input type="radio" value="month" id="newspack-donate-month-1462696087" name="donation_frequency" checked>
								<label for="newspack-donate-month-1462696087" class="donation-frequency-label">
									Monthly								</label>

								<div class="wp-block-newspack-blocks-donate__tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="5" id="newspack-tier-month-1462696087-0">
											<label class="tier-select-label" for="newspack-tier-month-1462696087-0">
												$5											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="10" id="newspack-tier-month-1462696087-1" checked>
											<label class="tier-select-label" for="newspack-tier-month-1462696087-1">
												$10											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_month" value="50" id="newspack-tier-month-1462696087-2">
											<label class="tier-select-label" for="newspack-tier-month-1462696087-2">
												$50											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_month" value="other" id="newspack-tier-month-1462696087-other">
										<label class="tier-select-label" for="newspack-tier-month-1462696087-other">
											Other										</label>
										<label class="other-donate-label" for="newspack-tier-month-1462696087-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_month_other" value="10" id="newspack-tier-month-1462696087-other-input">
										</div>
									</div>

								</div>
							</div>
						
							<div class="wp-block-newspack-blocks-donate__frequency">
								<input type="radio" value="year" id="newspack-donate-year-1462696087" name="donation_frequency">
								<label for="newspack-donate-year-1462696087" class="donation-frequency-label">
									Annually								</label>

								<div class="wp-block-newspack-blocks-donate__tiers">
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="60" id="newspack-tier-year-1462696087-0">
											<label class="tier-select-label" for="newspack-tier-year-1462696087-0">
												$60											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="120" id="newspack-tier-year-1462696087-1" checked>
											<label class="tier-select-label" for="newspack-tier-year-1462696087-1">
												$120											</label>
										</div>
																			<div class="wp-block-newspack-blocks-donate__tier">
																						<input type="radio" name="donation_value_year" value="600" id="newspack-tier-year-1462696087-2">
											<label class="tier-select-label" for="newspack-tier-year-1462696087-2">
												$600											</label>
										</div>
									
									<div class="wp-block-newspack-blocks-donate__tier">
																				<input type="radio" class="other-input" name="donation_value_year" value="other" id="newspack-tier-year-1462696087-other">
										<label class="tier-select-label" for="newspack-tier-year-1462696087-other">
											Other										</label>
										<label class="other-donate-label" for="newspack-tier-year-1462696087-other-input">
											Donation amount										</label>
										<div class="wp-block-newspack-blocks-donate__money-input">
											<span class="currency">
												$											</span>
											<input type="number" name="donation_value_year_other" value="120" id="newspack-tier-year-1462696087-other-input">
										</div>
									</div>

								</div>
							</div>
											</div>
				</div>
				<p class="wp-block-newspack-blocks-donate__thanks">
					Your contribution is appreciated.				</p>
				<button type="submit">
					Donate now!				</button>
							</form>
		</div>
		</div>
</div>
</div></div>



<p>The investigation determined that the Lexus driver was stopped at the stop sign on Meadowlane Avenue when he attempted to turn left onto State Highway 20, striking the Toyota. The Toyota spun several times, coming to rest a few feet away from the Lexus.</p>



<p>Police detected no signs of any impairment in either driver. The driver of the Camry had minor injuries. The Lexus driver, the only occupant of the vehicle, was treated and released by South Shore Rescue.</p>



<p>The unconscious passenger being treated at Ascension regained consciousness at the hospital and could speak with officers.</p>



<p>The incident remains under investigation by the Mount Pleasant Police Department and Wisconsin State Patrol. </p>



<hr class="wp-block-separator is-style-wide">


				<div class="wp-block-newspack-blocks-homepage-articles  wpnbha show-image image-alignleft ts-5 is-1 " style="">
			<div data-posts>
									<article data-post-id="376213" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/" rel="bookmark">
					<amp-img width="400" height="300" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Three-car crash, Mount Pleasant, Wisconsin" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?w=725&amp;ssl=1 725w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=80%2C60&amp;ssl=1 80w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;300&quot; width=&quot;400&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="400" height="300" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image" alt="Three-car crash, Mount Pleasant, Wisconsin" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?w=725&amp;ssl=1 725w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2019/11/mount-pleasant-police-2___25140748760.jpg?resize=80%2C60&amp;ssl=1 80w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/one-person-injured-in-mount-pleasant-crash/" rel="bookmark">One person injured in Mount Pleasant crash</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-29T07:31:19-05:00">May 29, 2020</time><time class="updated" datetime="2020-05-29T07:31:32-05:00">May 29, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376207" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/racine-man-held-on-75000-bond-after-attempted-homicide-charge/" rel="bookmark">
					<amp-img width="1200" height="900" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Deshon Martin, attempted homicide, Racine, Wisconsin" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?w=1280&amp;ssl=1 1280w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1044%2C783&amp;ssl=1 1044w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=632%2C474&amp;ssl=1 632w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=536%2C402&amp;ssl=1 536w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=706%2C530&amp;ssl=1 706w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;900&quot; width=&quot;1200&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="1200" height="900" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1200%2C900&amp;ssl=1" class="attachment-newspack-article-block-landscape-large size-newspack-article-block-landscape-large wp-post-image" alt="Deshon Martin, attempted homicide, Racine, Wisconsin" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?w=1280&amp;ssl=1 1280w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1200%2C900&amp;ssl=1 1200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=1044%2C783&amp;ssl=1 1044w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=632%2C474&amp;ssl=1 632w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=536%2C402&amp;ssl=1 536w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?resize=706%2C530&amp;ssl=1 706w" sizes="(max-width: 960px) 100vw, 960px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/racine-man-held-on-75000-bond-after-attempted-homicide-charge/" rel="bookmark">Racine man held on $75,000 bond after attempted homicide charge</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T17:26:42-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T17:26:58-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376190" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/brp-us-inc-to-layoff-387-people/" rel="bookmark">
					<amp-img width="800" height="600" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=800%2C600&amp;ssl=1" class="attachment-newspack-article-block-landscape-medium size-newspack-article-block-landscape-medium wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="BRP US Inc., Sturtevant, Wisconsin" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=632%2C474&amp;ssl=1 632w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=536%2C402&amp;ssl=1 536w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;800&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="800" height="600" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=800%2C600&amp;ssl=1" class="attachment-newspack-article-block-landscape-medium size-newspack-article-block-landscape-medium wp-post-image" alt="BRP US Inc., Sturtevant, Wisconsin" srcset="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=800%2C600&amp;ssl=1 800w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=400%2C300&amp;ssl=1 400w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=200%2C150&amp;ssl=1 200w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=632%2C474&amp;ssl=1 632w, https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?resize=536%2C402&amp;ssl=1 536w" sizes="(max-width: 800px) 100vw, 800px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/brp-us-inc-to-layoff-387-people/" rel="bookmark">BRP US Inc. to layoff 387 people</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T11:09:26-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T12:39:27-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376193" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/veteran-anthony-st-martin-enjoyed-cheering-on-the-cubs-and-packers/" rel="bookmark">
					<amp-img width="800" height="600" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=800%2C600&amp;ssl=1" class="attachment-newspack-article-block-landscape-medium size-newspack-article-block-landscape-medium wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=1044%2C783&amp;ssl=1 1044w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=632%2C474&amp;ssl=1 632w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=536%2C402&amp;ssl=1 536w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;800&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="800" height="600" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=800%2C600&amp;ssl=1" class="attachment-newspack-article-block-landscape-medium size-newspack-article-block-landscape-medium wp-post-image" alt="" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=200%2C150&amp;ssl=1 200w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=1044%2C783&amp;ssl=1 1044w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=632%2C474&amp;ssl=1 632w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Anthony-J-St-Martin-1.jpg?resize=536%2C402&amp;ssl=1 536w" sizes="(max-width: 800px) 100vw, 800px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/veteran-anthony-st-martin-enjoyed-cheering-on-the-cubs-and-packers/" rel="bookmark">Veteran Anthony St. Martin Enjoyed Cheering on the Cubs and Packers</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T11:08:05-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T11:08:16-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376176" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/summer-playground-program-registration-2/" rel="bookmark">
					<amp-img width="400" height="300" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=80%2C60&amp;ssl=1 80w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;300&quot; width=&quot;400&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="400" height="300" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image" alt="" srcset="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?resize=80%2C60&amp;ssl=1 80w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/summer-playground-program-registration-2/" rel="bookmark">Summer Playground Program Registration</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T10:30:22-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T10:09:40-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376166" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/city-of-racine-north-beach-swimming-opens/" rel="bookmark">
					<amp-img width="400" height="300" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="North Beach" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=80%2C60&amp;ssl=1 80w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;300&quot; width=&quot;400&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="400" height="300" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image" alt="North Beach" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?resize=80%2C60&amp;ssl=1 80w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>				</a>

							</figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/city-of-racine-north-beach-swimming-opens/" rel="bookmark">City of Racine North Beach Swimming Opens</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T09:30:27-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T09:31:58-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

			<article data-post-id="376162" class="post-has-image">
					<figure class="post-thumbnail">
				<a href="https://racinecountyeye.com/metered-parking-payments-resume-june-1st-in-city/" rel="bookmark">
					<amp-img width="400" height="300" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?zoom=2&amp;resize=400%2C300&amp;ssl=1 800w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;300&quot; width=&quot;400&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="400" height="300" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=400%2C300&amp;ssl=1" class="attachment-newspack-article-block-landscape-small size-newspack-article-block-landscape-small wp-post-image" alt="" srcset="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?zoom=2&amp;resize=400%2C300&amp;ssl=1 800w" sizes="(max-width: 400px) 100vw, 400px"></noscript></amp-img>

							</a></figure><!-- .featured-image -->
		
		<div class="entry-wrapper">
			<h2 class="entry-title"><a href="https://racinecountyeye.com/metered-parking-payments-resume-june-1st-in-city/" rel="bookmark">Metered Parking Payments Resume June 1st in City</a></h2>										<div class="entry-meta">
					<time class="entry-date published" datetime="2020-05-28T08:29:12-05:00">May 28, 2020</time><time class="updated" datetime="2020-05-28T08:35:17-05:00">May 28, 2020</time>				</div><!-- .entry-meta -->
					</div><!-- .entry-wrapper -->
	</article>

					</div>
			
		</div>
				<section id="custom_html-43" class="widget_text below-content widget widget_custom_html"><div class="textwidget custom-html-widget"><amp-iframe src="https://racinecountyeye.friends2follow.com/f2f/widget/html/socialstack/98/0/12/140/1/1/1/9/9/0" width="auto" height="649" frameborder="0" sandbox="allow-scripts allow-same-origin allow-popups" scrolling="no" layout="fixed-height" class="i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" style="height:649px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe src="https://racinecountyeye.friends2follow.com/f2f/widget/html/socialstack/98/0/12/140/1/1/1/9/9/0" width="100%" height="649px" frameborder="0" sandbox="allow-scripts allow-same-origin allow-popups" scrolling="no"></iframe></noscript></amp-iframe></div></section><section id="newspack-ads-widget-6" class="below-content widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21820527880/hs_300x250" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://racinecountyeye.com/tag/crash/" rel="tag">crash</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/mount-pleasant/" rel="tag">Mount Pleasant</a><span class="sep">, </span><a href="https://racinecountyeye.com/tag/wisconsin/" rel="tag">Wisconsin</a></span>	</footer><!-- .entry-footer -->

				
</article><!-- #post-${ID} -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
		<section id="custom_html-50" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.amazon.com/b?_encoding=UTF8&amp;tag=rce1-20&amp;linkCode=ur2&amp;linkId=db037a59f4eb8ade8baeb3412422f1c8&amp;camp=1789&amp;creative=9325&amp;node=3764441" rel="noopener noreferrer">RCE Wellness</a><amp-img src="//ir-na.amazon-adsystem.com/e/ir?t=rce1-20&amp;l=ur2&amp;o=1" width="1" height="1" alt="" class="amp-wp-enforced-sizes amp-wp-58686d1 i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" data-amp-original-style="border:none !important; margin:0px !important;" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;1&quot; width=&quot;1&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="//ir-na.amazon-adsystem.com/e/ir?t=rce1-20&amp;l=ur2&amp;o=1" width="1" height="1" border="0" alt="" data-amp-original-style="border:none !important; margin:0px !important;" class="amp-wp-58686d1"></noscript></amp-img></div></section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21820527880/hs_300x250" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section><section id="top-posts-3" class="widget widget_top-posts"><h2 class="widget-title accent-header"><span>Top Posts &amp; Pages</span></h2><ul class="widgets-list-layout no-grav">
					<li>
						<a href="https://racinecountyeye.com/brp-us-inc-to-layoff-387-people/" title="BRP US Inc. to layoff 387 people" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?fit=1200%2C599&amp;ssl=1&amp;resize=40%2C40" alt="BRP US Inc. to layoff 387 people" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Image14_2016-09-08-BRP-Q2-2017-RESULTS-CAN-AM-MAVERICK-X3.jpg?fit=1200%2C599&amp;ssl=1&amp;resize=40%2C40" alt="BRP US Inc. to layoff 387 people" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/brp-us-inc-to-layoff-387-people/" title="BRP US Inc. to layoff 387 people" class="bump-view" data-bump-view="tp">BRP US Inc. to layoff 387 people</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/city-of-racine-north-beach-swimming-opens/" title="City of Racine North Beach Swimming Opens" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?fit=512%2C339&amp;ssl=1&amp;resize=40%2C40" alt="City of Racine North Beach Swimming Opens" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2016/02/North-Beach-DSC_0101.jpg?fit=512%2C339&amp;ssl=1&amp;resize=40%2C40" alt="City of Racine North Beach Swimming Opens" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/city-of-racine-north-beach-swimming-opens/" title="City of Racine North Beach Swimming Opens" class="bump-view" data-bump-view="tp">City of Racine North Beach Swimming Opens</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/racine-man-held-on-75000-bond-after-attempted-homicide-charge/" title="Racine man held on $75,000 bond after attempted homicide charge" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?fit=1200%2C900&amp;ssl=1&amp;resize=40%2C40" alt="Racine man held on $75,000 bond after attempted homicide charge" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/Untitled-design-10.png?fit=1200%2C900&amp;ssl=1&amp;resize=40%2C40" alt="Racine man held on $75,000 bond after attempted homicide charge" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/racine-man-held-on-75000-bond-after-attempted-homicide-charge/" title="Racine man held on $75,000 bond after attempted homicide charge" class="bump-view" data-bump-view="tp">Racine man held on $75,000 bond after attempted homicide charge</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/" title="Home" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1-100x100.png" alt="Home" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://racinecountyeye.com/wp-content/uploads/2018/07/cropped-racine-county-eye-favicon-1-100x100.png" alt="Home" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/" title="Home" class="bump-view" data-bump-view="tp">Home</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/racine-county-communities-to-receive-millions-in-cares-act-dollars/" title="Racine County, communities to receive millions in CARES Act dollars" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/01/madison-wisconsin-state-capitol___21160802293.jpg?fit=725%2C544&amp;ssl=1&amp;resize=40%2C40" alt="Racine County, communities to receive millions in CARES Act dollars" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/01/madison-wisconsin-state-capitol___21160802293.jpg?fit=725%2C544&amp;ssl=1&amp;resize=40%2C40" alt="Racine County, communities to receive millions in CARES Act dollars" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/racine-county-communities-to-receive-millions-in-cares-act-dollars/" title="Racine County, communities to receive millions in CARES Act dollars" class="bump-view" data-bump-view="tp">Racine County, communities to receive millions in CARES Act dollars</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/man-who-died-in-motorcycle-crash-identified/" title="Man who died in motorcycle crash identified" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/bunko.png?fit=535%2C436&amp;ssl=1&amp;resize=40%2C40" alt="Man who died in motorcycle crash identified" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/bunko.png?fit=535%2C436&amp;ssl=1&amp;resize=40%2C40" alt="Man who died in motorcycle crash identified" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/man-who-died-in-motorcycle-crash-identified/" title="Man who died in motorcycle crash identified" class="bump-view" data-bump-view="tp">Man who died in motorcycle crash identified</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/metered-parking-payments-resume-june-1st-in-city/" title="Metered Parking Payments Resume June 1st in City" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?fit=879%2C571&amp;ssl=1&amp;resize=40%2C40" alt="Metered Parking Payments Resume June 1st in City" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2019/02/parking-meters.jpg?fit=879%2C571&amp;ssl=1&amp;resize=40%2C40" alt="Metered Parking Payments Resume June 1st in City" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/metered-parking-payments-resume-june-1st-in-city/" title="Metered Parking Payments Resume June 1st in City" class="bump-view" data-bump-view="tp">Metered Parking Payments Resume June 1st in City</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/covid-19-update-from-ascension-wisconsin/" title="COVID-19 Update From Ascension Wisconsin" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/03/global-coronavirus.jpg?fit=990%2C701&amp;ssl=1&amp;resize=40%2C40" alt="COVID-19 Update From Ascension Wisconsin" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i2.wp.com/racinecountyeye.com/wp-content/uploads/2020/03/global-coronavirus.jpg?fit=990%2C701&amp;ssl=1&amp;resize=40%2C40" alt="COVID-19 Update From Ascension Wisconsin" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/covid-19-update-from-ascension-wisconsin/" title="COVID-19 Update From Ascension Wisconsin" class="bump-view" data-bump-view="tp">COVID-19 Update From Ascension Wisconsin</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/summer-playground-program-registration-2/" title="Summer Playground Program Registration" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?fit=513%2C525&amp;ssl=1&amp;resize=40%2C40" alt="Summer Playground Program Registration" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i0.wp.com/racinecountyeye.com/wp-content/uploads/2015/09/Mitchell-Playground.jpg?fit=513%2C525&amp;ssl=1&amp;resize=40%2C40" alt="Summer Playground Program Registration" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/summer-playground-program-registration-2/" title="Summer Playground Program Registration" class="bump-view" data-bump-view="tp">Summer Playground Program Registration</a>
							</div>
													</li>
										<li>
						<a href="https://racinecountyeye.com/current-business-openings/" title="Current Business Openings" class="bump-view" data-bump-view="tp">
								<amp-img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/open-sign.jpg?fit=874%2C582&amp;ssl=1&amp;resize=40%2C40" alt="Current Business Openings" data-pin-nopin="true" class="widgets-list-layout-blavatar amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;40&quot; width=&quot;40&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="40" height="40" src="https://i1.wp.com/racinecountyeye.com/wp-content/uploads/2020/05/open-sign.jpg?fit=874%2C582&amp;ssl=1&amp;resize=40%2C40" alt="Current Business Openings" class="widgets-list-layout-blavatar"></noscript></amp-img>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://racinecountyeye.com/current-business-openings/" title="Current Business Openings" class="bump-view" data-bump-view="tp">Current Business Openings</a>
							</div>
													</li>
					</ul>
</section><section id="custom_html-45" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></section><section id="tribe-events-list-widget-6" class="widget tribe-events-list-widget"><h2 class="widget-title accent-header"><span>Upcoming Events</span></h2>	<p>There are no upcoming events at this time.</p>
</section><section id="custom_html-52" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- BEGIN Foreclosure Widget -->

<div data-amp-original-style="padding: 5px 10px 5px;" class="amp-wp-68ea15f"></div><div data-amp-original-style="padding: 5px 10px 5px; font-size:10px; color:#999999; font-family:Arial, Helvetica, sans-serif; clear:both;height:12px" class="amp-wp-0906a55">Powered by <a href="https://www.foreclosure.com/?rsp=3121" title="Foreclosure listings" data-amp-original-style="font-size:10px; color:#999999; text-align:right;" class="amp-wp-3560101">Foreclosure.com</a></div>
<!-- END Foreclosure Widget --></div></section><section id="custom_html-54" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div data-amp-original-style="clear: both; width: 300px; height: 250px; border: 1px solid #CCC; background: url(https://associate.foreclosure.com/accounts/default1/banners/e6fb9bab.jpg) top left no-repeat #fff; position:relative; margin:0; padding:0;" class="amp-wp-b3b3126">
<a href="https://www.foreclosure.com?rsp=10519"><div data-amp-original-style="position: absolute; width: 297px; height: 140px;" class="amp-wp-ef84f20"> </div></a>
  <form action="https://www.foreclosure.com/listing/search" method="get" target="_top">
    <input name="q" type="text" placeholder="Enter Zip Code" data-amp-original-style="width: 161px; height: 34px; font-family: Arial, Helvetica, sans-serif; text-align: left; font-size: 15px; color: #a6a3a3; font-weight: normald; position: absolute; top: 204px; left: 18px; margin: 0; padding: 0 0 0 12px; border: #9ba1a1 solid 1px;" class="amp-wp-9b45e63">
    <input type="hidden" value="10519" name="rsp">
    <input type="hidden" value="dd601e99" name="a_bid">
    <input type="hidden" value="" name="chan">
    <input type="submit" value="Search" data-amp-original-style="background-color: #f26522; color: #FFF; font-weight: 800; width: 91px; height: 36px; position: absolute; top: 204px; left: 192px; border: 0; margin: 0; padding: 0; cursor: pointer; border-top-right-radius: 6px; border-bottom-right-radius: 6px; font-stretch: condensed; font-size: 16px;" class="amp-wp-05d04c8">
  </form>
</div></div></section>	</aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


			<div class="newspack_global_ad global_above_footer">
			<div id="div-gpt-amp-et_728x90-5ed10ce9902cf-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21820527880/et_728x90" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> 
		</div>
		
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

				
		<div class="site-info">

				<aside class="widget-area" role="complementary" aria-label="Below Footer">
		<div class="wrapper">
			<section id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widget-title">Copyright</h2><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-29815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29815"><a href="https://racinecountyeye.com/about/">About</a></li>
<li id="menu-item-29816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29816"><a href="https://racinecountyeye.com/grow-business-low-cost-advertising-solutions/">Grow your business with the Racine County Eye</a></li>
<li id="menu-item-29817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29817"><a href="https://racinecountyeye.com/contact/">Contact</a></li>
<li id="menu-item-354317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-354317"><a href="https://www.racinecountyeye.com/privacy-policy/">Privacy policy</a></li>
</ul></div></section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->

			<div class="wrapper site-info-contain">
													<span class="copyright">© 2020 Local News I Racine County Eye - Racine, Wisconsin.</span>
				
				<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress.				</a>

				<a class="privacy-policy-link" href="https://racinecountyeye.com/terms-conditions/">Terms &amp; Conditions</a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-icons-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29805"><a href="http://facebook.com/racinecountyeye"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29806"><a href="http://twitter.com/racinecountyeye"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29807"><a href="http://youtube.com/user/racinecountyeye"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29808"><a href="http://racinecountyeye.com/feed"><span class="screen-reader-text">RSS Feed</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M2,8.667V12c5.515,0,10,4.485,10,10h3.333C15.333,14.637,9.363,8.667,2,8.667z M2,2v3.333 c9.19,0,16.667,7.477,16.667,16.667H22C22,10.955,13.045,2,2,2z M4.5,17C3.118,17,2,18.12,2,19.5S3.118,22,4.5,22S7,20.88,7,19.5 S5.882,17,4.5,17z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
			</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

	<amp-state id="newspackHomepagePosts" class="i-amphtml-layout-container" i-amphtml-layout="container">
		<script type="application/json">
			{
				"exclude_ids": [ 376213, 376207, 376190, 376193, 376176, 376166, 376162 ]
			}
		</script>
	</amp-state>
			
		<!-- Jetpack Google Analytics -->
			
	<div data-amp-original-style="display:none" class="amp-wp-cb45893">
	<div class="grofile-hash-map-29efedfcd2683140ac59e4e397964012">
	</div>
	<div class="grofile-hash-map-8774d6416866e8864e8e110377e97853">
	</div>
	<div class="grofile-hash-map-992b81fd0348eeb168d8eb3d77c24a89">
	</div>
	</div>
			<!-- Facebook Pixel Code -->
			<!--noscript-->
				<amp-img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" class="amp-wp-enforced-sizes amp-wp-6a19fc1 i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" data-amp-original-style="display:inline-block" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;1&quot; width=&quot;1&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img height="1" width="1" alt="fbpx" src="https://www.facebook.com/tr?id=358503254999422&amp;ev=PageView&amp;noscript=1" data-amp-original-style="display:none" class="amp-wp-cb45893"></noscript></amp-img>
			<!--/noscript-->
			<!-- End Facebook Pixel Code -->
					<amp-install-serviceworker src="/?wp_service_worker=1" data-iframe-src="https://racinecountyeye.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
				<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{"vars":{"gtag_id":"UA-128295961-1","config":{"UA-128295961-1":{"groups":"default","linker":{"domains":["racinecountyeye.com"]}}}},"optoutElementId":"__gaOptOutExtension"}			</script>
		</amp-analytics>
				<!-- Google Tag Manager added by Site Kit -->
		<amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-P7DVBXQ" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
			<script type="application/json">
				{"optoutElementId":"__gaOptOutExtension"}			</script>
		</amp-analytics>
		<!-- End Google Tag Manager -->
			
	














































































































	<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A8.5&amp;blog=172500100&amp;post=376213&amp;tz=-5&amp;srv=racinecountyeye.com&amp;host=racinecountyeye.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 247 seconds ago
	generated in 1.238 seconds
	served from batcache in 0.003 seconds
	expires in 53 seconds
-->
